(file) Return to tog-pegasus-preun.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm / tog-specfiles

File: [Pegasus] / pegasus / rpm / tog-specfiles / tog-pegasus-preun.spec (download)
Revision: 1.13, Tue Mar 11 02:46:16 2014 UTC (10 years, 2 months ago) by dl.meetei
Branch: MAIN
CVS Tags: preBug9676, postBug9676, TASK-PEP317_pullop-merged_out_from_trunk, TASK-PEP317_pullop-merged_in_to_trunk, RELEASE_2_14_1, RELEASE_2_14_0-RC2, RELEASE_2_14_0-RC1, RELEASE_2_14_0, RELEASE_2_14-root, RELEASE_2_14-branch, HEAD
Changes since 1.12: +4 -0 lines
BUG#: 9843
TITLE: pegasus rpm uninstallation does not remove ssl certs and cnf

DESCRIPTION:

# Start of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
#           install   remove   upgrade  reinstall
#  preun       -        0         1         -
if [ $1 -eq 0 ]; then
   # Check if the cimserver is running
   isRunning=`ps -el | grep cimserver |  grep -v "grep cimserver"`
   if [ "$isRunning" ]; then
      %PEGASUS_SBIN_DIR/cimserver -s
   fi
   /sbin/chkconfig --del %{Flavor}-pegasus;
   rm -f %PEGASUS_CONFIG_DIR/cimserver_current.conf;
   [ -d %PEGASUS_REPOSITORY_DIR ]  && rm -rf %PEGASUS_REPOSITORY_DIR;
   [ -d %PEGASUS_VARDATA_CACHE_DIR ]  && rm -rf %PEGASUS_VARDATA_CACHE_DIR;
   rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
   rm -f %PEGASUS_CIMSERVER_START_FILE;
   rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
   rm -f %PEGASUS_CONFIG_DIR/%PEGASUS_SSL_CERT_FILE
   rm -f %PEGASUS_CONFIG_DIR/%PEGASUS_SSL_KEY_FILE
   rm -f %PEGASUS_CONFIG_DIR/%PEGASUS_SSL_TRUSTSTORE
   rm -f %PEGASUS_CONFIG_DIR/ssl.cnf
fi
#
# End of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2