(file) Return to tog-pegasus-preun.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm / tog-specfiles

 1 martin 1.7 #//%LICENSE////////////////////////////////////////////////////////////////
 2 martin 1.8 #//
 3 martin 1.7 #// Licensed to The Open Group (TOG) under one or more contributor license
 4            #// agreements.  Refer to the OpenPegasusNOTICE.txt file distributed with
 5            #// this work for additional information regarding copyright ownership.
 6            #// Each contributor licenses this file to you under the OpenPegasus Open
 7            #// Source License; you may not use this file except in compliance with the
 8            #// License.
 9 martin 1.8 #//
10 martin 1.7 #// Permission is hereby granted, free of charge, to any person obtaining a
11            #// copy of this software and associated documentation files (the "Software"),
12            #// to deal in the Software without restriction, including without limitation
13            #// the rights to use, copy, modify, merge, publish, distribute, sublicense,
14            #// and/or sell copies of the Software, and to permit persons to whom the
15            #// Software is furnished to do so, subject to the following conditions:
16 martin 1.8 #//
17 martin 1.7 #// The above copyright notice and this permission notice shall be included
18            #// in all copies or substantial portions of the Software.
19 martin 1.8 #//
20 martin 1.7 #// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
21 martin 1.8 #// OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
22 martin 1.7 #// MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
23            #// IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
24            #// CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
25            #// TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
26            #// SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
27 martin 1.8 #//
28 martin 1.7 #//////////////////////////////////////////////////////////////////////////
29 denise.eckstein 1.1 # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
30                     #           install   remove   upgrade  reinstall
31                     #  preun       -        0         1         -
32                     if [ $1 -eq 0 ]; then
33                        # Check if the cimserver is running
34                        isRunning=`ps -el | grep cimserver |  grep -v "grep cimserver"`
35                        if [ "$isRunning" ]; then
36                           %PEGASUS_SBIN_DIR/cimserver -s
37                        fi 
38                        /sbin/chkconfig --del tog-pegasus;
39                        rm -f %PEGASUS_VARDATA_DIR/cimserver_current.conf;
40                        [ -d %PEGASUS_REPOSITORY_DIR ]  && rm -rf %PEGASUS_REPOSITORY_DIR;
41                        [ -d %PEGASUS_VARDATA_CACHE_DIR ]  && rm -rf %PEGASUS_VARDATA_CACHE_DIR;
42                        rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
43                        rm -f %PEGASUS_CIMSERVER_START_FILE;
44 kumpf           1.5    rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
45 denise.eckstein 1.1 fi
46                     #
47                     # End of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2