(file) Return to tog-pegasus-preun.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm / tog-specfiles

 1 a.dunfey 1.1.2.1 #//%2006////////////////////////////////////////////////////////////////////////
 2                  #//
 3                  #// Copyright (c) 2000, 2001, 2002 BMC Software; Hewlett-Packard Development
 4                  #// Company, L.P.; IBM Corp.; The Open Group; Tivoli Systems.
 5                  #// Copyright (c) 2003 BMC Software; Hewlett-Packard Development Company, L.P.;
 6                  #// IBM Corp.; EMC Corporation, The Open Group.
 7                  #// Copyright (c) 2004 BMC Software; Hewlett-Packard Development Company, L.P.;
 8                  #// IBM Corp.; EMC Corporation; VERITAS Software Corporation; The Open Group.
 9                  #// Copyright (c) 2005 Hewlett-Packard Development Company, L.P.; IBM Corp.;
10                  #// EMC Corporation; VERITAS Software Corporation; The Open Group.
11                  #// Copyright (c) 2006 Hewlett-Packard Development Company, L.P.; IBM Corp.;
12                  #// EMC Corporation; Symantec Corporation; The Open Group.
13                  #//
14                  #// Permission is hereby granted, free of charge, to any person obtaining a copy
15                  #// of this software and associated documentation files (the "Software"), to
16                  #// deal in the Software without restriction, including without limitation the
17                  #// rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
18                  #// sell copies of the Software, and to permit persons to whom the Software is
19                  #// furnished to do so, subject to the following conditions:
20                  #// 
21                  #// THE ABOVE COPYRIGHT NOTICE AND THIS PERMISSION NOTICE SHALL BE INCLUDED IN
22 a.dunfey 1.1.2.1 #// ALL COPIES OR SUBSTANTIAL PORTIONS OF THE SOFTWARE. THE SOFTWARE IS PROVIDED
23                  #// "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
24                  #// LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
25                  #// PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
26                  #// HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
27                  #// ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
28                  #// WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
29                  #//
30                  #//==============================================================================
31 denise.eckstein 1.1     # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
32                         #           install   remove   upgrade  reinstall
33                         #  preun       -        0         1         -
34                         if [ $1 -eq 0 ]; then
35                            # Check if the cimserver is running
36                            isRunning=`ps -el | grep cimserver |  grep -v "grep cimserver"`
37                            if [ "$isRunning" ]; then
38                               %PEGASUS_SBIN_DIR/cimserver -s
39                            fi 
40                            /sbin/chkconfig --del tog-pegasus;
41                            rm -f %PEGASUS_VARDATA_DIR/cimserver_current.conf;
42                            rm -f %PEGASUS_INSTALL_LOG;
43                            [ -d %PEGASUS_REPOSITORY_DIR ]  && rm -rf %PEGASUS_REPOSITORY_DIR;
44                            [ -d %PEGASUS_VARDATA_CACHE_DIR ]  && rm -rf %PEGASUS_VARDATA_CACHE_DIR;
45                            rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
46                            rm -f %PEGASUS_CIMSERVER_START_FILE;
47 a.dunfey        1.1.2.1    rm -f %CIMSERVER_LOCK_FILE;
48 denise.eckstein 1.1     fi
49                         #
50                         # End of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2