(file) Return to tog-pegasus-pre.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm / tog-specfiles

 1 martin 1.9 #//%LICENSE////////////////////////////////////////////////////////////////
 2            #// 
 3            #// Licensed to The Open Group (TOG) under one or more contributor license
 4            #// agreements.  Refer to the OpenPegasusNOTICE.txt file distributed with
 5            #// this work for additional information regarding copyright ownership.
 6            #// Each contributor licenses this file to you under the OpenPegasus Open
 7            #// Source License; you may not use this file except in compliance with the
 8            #// License.
 9            #// 
10            #// Permission is hereby granted, free of charge, to any person obtaining a
11            #// copy of this software and associated documentation files (the "Software"),
12            #// to deal in the Software without restriction, including without limitation
13            #// the rights to use, copy, modify, merge, publish, distribute, sublicense,
14            #// and/or sell copies of the Software, and to permit persons to whom the
15            #// Software is furnished to do so, subject to the following conditions:
16            #// 
17            #// The above copyright notice and this permission notice shall be included
18            #// in all copies or substantial portions of the Software.
19            #// 
20            #// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
21            #// OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 
22 martin 1.9 #// MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
23            #// IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
24            #// CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
25            #// TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
26            #// SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
27            #// 
28            #//////////////////////////////////////////////////////////////////////////
29 denise.eckstein 1.3 # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec
30                     #           install   remove   upgrade  reinstall
31                     # pre          1        -         2         2
32                     #
33                     # If it exists, the active OpenPegasus Repository
34                     #    directory, %PEGASUS_REPOSITORY_DIR is renamed
35                     #    to %PEGASUS_PREV_REPOSITORY_DIR.  If
36                     #    %PEGASUS_PREV_REPOSITORY_DIR already exists,
37                     #    it is saved as an archive file.
38                     
39                     if [ -d %PEGASUS_REPOSITORY_DIR"/root#PG_Internal" ]; then
40                        #
41                        # Save the current repository to prev_repository
42                        #
43                        if [ -d %PEGASUS_PREV_REPOSITORY_DIR ]; then
44                             /bin/tar -C %PEGASUS_REPOSITORY_PARENT_DIR -cf \
45                                 %PEGASUS_PREV_REPOSITORY_DIR`date '+%Y-%m-%d-%s.%N'`.tar \
46                                 %PEGASUS_PREV_REPOSITORY_DIR_NAME
47                             rm -rf %PEGASUS_PREV_REPOSITORY_DIR
48                        fi
49                        /bin/mv %PEGASUS_REPOSITORY_DIR %PEGASUS_PREV_REPOSITORY_DIR
50 denise.eckstein 1.1 fi
51 w.otsuka        1.4 if [ $1 -gt 0 ]; then
52 denise.eckstein 1.3    #  Create the 'pegasus' user and group:
53                        /usr/sbin/groupadd pegasus > /dev/null 2>&1 || :;
54                        /usr/sbin/useradd -c "tog-pegasus OpenPegasus WBEM/CIM services" \
55                             -g pegasus -s /sbin/nologin -r -d %PEGASUS_VARDATA_DIR pegasus \
56                              > /dev/null 2>&1 || :;
57                     fi
58 yi.zhou         1.7 if [ $1 -eq 2 ]; then
59                         rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
60                         rm -f %PEGASUS_CIMSERVER_START_FILE;
61 yi.zhou         1.8     rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
62 yi.zhou         1.7 fi
63 denise.eckstein 1.3 #
64                     # End of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2