(file) Return to tog-pegasus-pre.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm / tog-specfiles

 1 karl  1.5 #//%2006////////////////////////////////////////////////////////////////////////
 2           #//
 3           #// Copyright (c) 2000, 2001, 2002 BMC Software; Hewlett-Packard Development
 4           #// Company, L.P.; IBM Corp.; The Open Group; Tivoli Systems.
 5           #// Copyright (c) 2003 BMC Software; Hewlett-Packard Development Company, L.P.;
 6           #// IBM Corp.; EMC Corporation, The Open Group.
 7           #// Copyright (c) 2004 BMC Software; Hewlett-Packard Development Company, L.P.;
 8           #// IBM Corp.; EMC Corporation; VERITAS Software Corporation; The Open Group.
 9           #// Copyright (c) 2005 Hewlett-Packard Development Company, L.P.; IBM Corp.;
10           #// EMC Corporation; VERITAS Software Corporation; The Open Group.
11           #// Copyright (c) 2006 Hewlett-Packard Development Company, L.P.; IBM Corp.;
12           #// EMC Corporation; Symantec Corporation; The Open Group.
13           #//
14           #// Permission is hereby granted, free of charge, to any person obtaining a copy
15           #// of this software and associated documentation files (the "Software"), to
16           #// deal in the Software without restriction, including without limitation the
17           #// rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
18           #// sell copies of the Software, and to permit persons to whom the Software is
19           #// furnished to do so, subject to the following conditions:
20           #// 
21           #// THE ABOVE COPYRIGHT NOTICE AND THIS PERMISSION NOTICE SHALL BE INCLUDED IN
22 karl  1.5 #// ALL COPIES OR SUBSTANTIAL PORTIONS OF THE SOFTWARE. THE SOFTWARE IS PROVIDED
23           #// "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
24           #// LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
25           #// PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
26           #// HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
27           #// ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
28           #// WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
29           #//
30           #//==============================================================================
31 denise.eckstein 1.3 # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec
32                     #           install   remove   upgrade  reinstall
33                     # pre          1        -         2         2
34                     #
35                     # If it exists, the active OpenPegasus Repository
36                     #    directory, %PEGASUS_REPOSITORY_DIR is renamed
37                     #    to %PEGASUS_PREV_REPOSITORY_DIR.  If
38                     #    %PEGASUS_PREV_REPOSITORY_DIR already exists,
39                     #    it is saved as an archive file.
40                     
41                     if [ -d %PEGASUS_REPOSITORY_DIR"/root#PG_Internal" ]; then
42                        #
43                        # Save the current repository to prev_repository
44                        #
45                        if [ -d %PEGASUS_PREV_REPOSITORY_DIR ]; then
46                             /bin/tar -C %PEGASUS_REPOSITORY_PARENT_DIR -cf \
47                                 %PEGASUS_PREV_REPOSITORY_DIR`date '+%Y-%m-%d-%s.%N'`.tar \
48                                 %PEGASUS_PREV_REPOSITORY_DIR_NAME
49                             rm -rf %PEGASUS_PREV_REPOSITORY_DIR
50                        fi
51                        /bin/mv %PEGASUS_REPOSITORY_DIR %PEGASUS_PREV_REPOSITORY_DIR
52 denise.eckstein 1.1 fi
53 w.otsuka        1.4 if [ $1 -gt 0 ]; then
54 denise.eckstein 1.3    #  Create the 'pegasus' user and group:
55                        /usr/sbin/groupadd pegasus > /dev/null 2>&1 || :;
56                        /usr/sbin/useradd -c "tog-pegasus OpenPegasus WBEM/CIM services" \
57                             -g pegasus -s /sbin/nologin -r -d %PEGASUS_VARDATA_DIR pegasus \
58                              > /dev/null 2>&1 || :;
59                     fi
60                     #
61                     # End of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2