(file) Return to tog-pegasus.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm

  1 martin 1.115 #//%LICENSE////////////////////////////////////////////////////////////////
  2 martin 1.116 #//
  3 martin 1.115 #// Licensed to The Open Group (TOG) under one or more contributor license
  4              #// agreements.  Refer to the OpenPegasusNOTICE.txt file distributed with
  5              #// this work for additional information regarding copyright ownership.
  6              #// Each contributor licenses this file to you under the OpenPegasus Open
  7              #// Source License; you may not use this file except in compliance with the
  8              #// License.
  9 martin 1.116 #//
 10 martin 1.115 #// Permission is hereby granted, free of charge, to any person obtaining a
 11              #// copy of this software and associated documentation files (the "Software"),
 12              #// to deal in the Software without restriction, including without limitation
 13              #// the rights to use, copy, modify, merge, publish, distribute, sublicense,
 14              #// and/or sell copies of the Software, and to permit persons to whom the
 15              #// Software is furnished to do so, subject to the following conditions:
 16 martin 1.116 #//
 17 martin 1.115 #// The above copyright notice and this permission notice shall be included
 18              #// in all copies or substantial portions of the Software.
 19 martin 1.116 #//
 20 martin 1.115 #// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
 21 martin 1.116 #// OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
 22 martin 1.115 #// MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
 23              #// IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
 24              #// CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
 25              #// TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
 26              #// SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
 27 martin 1.116 #//
 28 martin 1.115 #//////////////////////////////////////////////////////////////////////////
 29 w.otsuka 1.1   #%/////////////////////////////////////////////////////////////////////////////
 30                #
 31                # tog-pegasus.spec
 32                #
 33 denise.eckstein 1.32  #%/////////////////////////////////////////////////////////////////////////////
 34                       
 35                       #
 36 kumpf           1.119 # WARNING: This file is automatically generated by executing
 37 denise.eckstein 1.32  #   make -f pegasus/Makefile.Release create_OpenPegasusRPMSpecFile
 38 denise.eckstein 1.74  # Any changes made directly to this file in the OpenPegasus source will
 39                       # be lost the next time this file is regenerated and submitted to CVS.
 40 w.otsuka        1.1   #
 41 denise.eckstein 1.32  
 42 dave.sudlik     1.107 %define packageVersion 1
 43 denise.eckstein 1.120 Version: 2.10.0
 44 denise.eckstein 1.102 Release: %{packageVersion}%{?LINUX_VERSION:.%{LINUX_VERSION}}
 45 w.otsuka        1.56  Epoch:   1
 46 denise.eckstein 1.32  
 47                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-intro.spec
 48 denise.eckstein 1.74  #
 49 w.otsuka        1.56  %{?!PEGASUS_BUILD_TEST_RPM:   %define PEGASUS_BUILD_TEST_RPM        0}
 50 denise.eckstein 1.74  # do "rpmbuild --define 'PEGASUS_BUILD_TEST_RPM 1'" to build test RPM.
 51                       #
 52                       %{?!AUTOSTART:   %define AUTOSTART        0}
 53                       # Use "rpm -[iU]vh --define 'AUTOSTART 1'" in order to have cimserver enabled
 54                       # (chkconfig --level=345 tog-pegasus on) after installation.
 55                       #
 56 s.kodali        1.121 # Use "rpmbuild --define 'JMPI_PROVIDER_REQUESTED 1'" to include JMPI support.
 57                       %{?!JMPI_PROVIDER_REQUESTED: %define JMPI_PROVIDER_REQUESTED 0}
 58 denise.eckstein 1.74  
 59                       Summary:   OpenPegasus WBEM Services for Linux
 60                       Name:      tog-pegasus
 61                       Group:     Systems Management/Base
 62                       License:   Open Group Pegasus Open Source
 63                       BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 64                       URL:       http://www.openpegasus.org
 65                       
 66 denise.eckstein 1.102 Source:    %{name}-%{version}-%{packageVersion}.tar.gz
 67 yi.zhou         1.93  #
 68                       # End of section pegasus/rpm/tog-specfiles/tog-pegasus-intro.spec
 69 denise.eckstein 1.74  
 70 yi.zhou         1.93  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-buildRequires.spec
 71                       #
 72 denise.eckstein 1.74  BuildRequires:      bash, sed, grep, coreutils, procps, gcc, gcc-c++
 73                       BuildRequires:      libstdc++, make, pam-devel
 74                       BuildRequires:      openssl-devel >= 0.9.6, e2fsprogs
 75 s.kodali        1.121 %if %{JMPI_PROVIDER_REQUESTED}
 76                       BuildRequires:      gcc-java, libgcj-devel, libgcj, java-1.4.2-gcj-compat
 77                       Requires:           libgcj, java-1.4.2-gcj-compat
 78                       %endif
 79 yi.zhou         1.93  BuildRequires:      net-snmp-devel
 80                       #
 81                       # End of section  pegasus/rpm/tog-specfiles/tog-pegasus-buildRequires.spec
 82                       
 83                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-requires.spec
 84                       #
 85 denise.eckstein 1.74  Requires:           bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 86                       #Requires:          krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 87                       Requires:           e2fsprogs, bind-utils, net-tools
 88                       Requires(post):     bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 89                       #Requires(post):    krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 90                       Requires(post):     e2fsprogs, bind-utils, net-tools
 91                       Requires(pre):      bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 92                       #Requires(pre):     krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 93                       Requires(pre):      e2fsprogs, bind-utils, net-tools
 94                       Requires(postun):   bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 95                       #Requires(postun):  krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 96                       Requires(postun):   e2fsprogs, bind-utils, net-tools
 97 yi.zhou         1.93  Requires:           net-snmp
 98                       #
 99                       # End of section  pegasus/rpm/tog-specfiles/tog-pegasus-requires.spec
100 denise.eckstein 1.74  
101 yi.zhou         1.93  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-desc.spec
102                       #
103 w.otsuka        1.73  Conflicts: openwbem
104 denise.eckstein 1.32  Provides: tog-pegasus-cimserver
105 w.otsuka        1.64  BuildConflicts: tog-pegasus
106 w.otsuka        1.1   
107                       %description
108 w.otsuka        1.9   OpenPegasus WBEM Services for Linux enables management solutions that deliver
109 w.otsuka        1.1   increased control of enterprise resources. WBEM is a platform and resource
110                       independent DMTF standard that defines a common information model and
111                       communication protocol for monitoring and controlling resources from diverse
112                       sources.
113 denise.eckstein 1.74  #
114 yi.zhou         1.93  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-desc.spec
115 w.otsuka        1.1   
116 denise.eckstein 1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-arch.spec
117                       #
118 w.otsuka        1.54  %ifarch ia64
119 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_IA64_GNU
120 w.otsuka        1.1   %else
121 w.otsuka        1.54  %ifarch x86_64
122                       %global PEGASUS_HARDWARE_PLATFORM LINUX_X86_64_GNU
123                       %else
124 w.otsuka        1.24  %ifarch ppc
125 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_PPC_GNU
126 w.otsuka        1.24  %else
127 denise.eckstein 1.44  %ifarch ppc64 pseries
128 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_PPC64_GNU
129 w.otsuka        1.24  %else
130                       %ifarch s390
131 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_ZSERIES_GNU
132 w.otsuka        1.24  %else
133                       %ifarch s390x zseries
134 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_ZSERIES64_GNU
135 w.otsuka        1.24  %else
136 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_IX86_GNU
137 kumpf           1.119 %endif
138                       %endif
139                       %endif
140                       %endif
141 w.otsuka        1.1   %endif
142 w.otsuka        1.24  %endif
143 denise.eckstein 1.74  #
144                       # End of section pegasus/rpm/tog-specfiles/tog-pegasus-arch.spec
145 w.otsuka        1.55  
146 denise.eckstein 1.81  %global PEGASUS_ARCH_LIB %{_lib}
147 w.otsuka        1.86  %global OPENSSL_HOME /usr
148 denise.eckstein 1.81  %global OPENSSL_BIN /usr/bin
149                       %global PEGASUS_PEM_DIR /etc/Pegasus
150                       %global PEGASUS_SSL_CERT_FILE server.pem
151                       %global PEGASUS_SSL_KEY_FILE file.pem
152                       %global PEGASUS_SSL_TRUSTSTORE client.pem
153                       %global PAM_CONFIG_DIR /etc/pam.d
154                       %global PEGASUS_CONFIG_DIR /etc/Pegasus
155                       %global PEGASUS_VARDATA_DIR /var/lib/Pegasus
156                       %global PEGASUS_VARDATA_CACHE_DIR /var/lib/Pegasus/cache
157                       %global PEGASUS_LOCAL_DOMAIN_SOCKET_PATH  /var/run/tog-pegasus/socket/cimxml.socket
158                       %global PEGASUS_CIMSERVER_START_FILE /var/run/tog-pegasus/cimserver.pid
159 yi.zhou         1.98  %global PEGASUS_TRACE_FILE_PATH /var/lib/Pegasus/cache/trace/cimserver.trc
160 kumpf           1.94  %global PEGASUS_CIMSERVER_START_LOCK_FILE /var/run/tog-pegasus/cimserver_start.lock
161 denise.eckstein 1.81  %global PEGASUS_REPOSITORY_DIR /var/lib/Pegasus/repository
162                       %global PEGASUS_PREV_REPOSITORY_DIR_NAME prev_repository
163                       %global PEGASUS_REPOSITORY_PARENT_DIR /var/lib/Pegasus
164                       %global PEGASUS_PREV_REPOSITORY_DIR /var/lib/Pegasus/prev_repository
165                       %global PEGASUS_SBIN_DIR /usr/sbin
166 denise.eckstein 1.120 %global PEGASUS_DOC_DIR /usr/share/doc/tog-pegasus-2.10
167 denise.eckstein 1.81  
168                       %global PEGASUS_RPM_ROOT  $RPM_BUILD_DIR/$RPM_PACKAGE_NAME-$RPM_PACKAGE_VERSION
169 denise.eckstein 1.95  %global PEGASUS_RPM_HOME %PEGASUS_RPM_ROOT/build
170 denise.eckstein 1.81  %global PEGASUS_INSTALL_LOG /var/lib/Pegasus/log/install.log
171                       
172 denise.eckstein 1.32  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-packages.spec
173 denise.eckstein 1.74  #
174 w.otsuka        1.69  %package devel
175 denise.eckstein 1.32  Summary: The OpenPegasus Software Development Kit
176                       Group: Systems Management/Base
177                       Requires: tog-pegasus >= %{version}
178 w.otsuka        1.69  Obsoletes: tog-pegasus-sdk
179 w.otsuka        1.1   
180 w.otsuka        1.69  %description devel
181 denise.eckstein 1.74  The OpenPegasus WBEM Services for Linux SDK is the developer's kit for the
182                       OpenPegasus WBEM Services for Linux release. It provides Linux C++ developers
183                       with the WBEM files required to build WBEM Clients and Providers. It also
184                       supports C provider developers via the CMPI interface.
185 w.otsuka        1.1   
186 w.otsuka        1.56  %if %{PEGASUS_BUILD_TEST_RPM}
187 denise.eckstein 1.32  %package test
188                       Summary: The OpenPegasus Tests
189                       Group: Systems Management/Base
190 kumpf           1.119 Requires: tog-pegasus >= %{version}
191 w.otsuka        1.1   
192 denise.eckstein 1.32  %description test
193                       The OpenPegasus WBEM tests for the OpenPegasus %{version} Linux rpm.
194 w.otsuka        1.56  %endif
195 denise.eckstein 1.74  #
196                       #End of section pegasus/rpm/tog-specfiles/tog-pegasus-packages.spec
197 w.otsuka        1.1   
198 denise.eckstein 1.32  %prep
199 denise.eckstein 1.74  %setup -q -n %{name}-%{version}
200 w.otsuka        1.28  
201 denise.eckstein 1.32  %build
202                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-build.spec
203 denise.eckstein 1.74  #
204 denise.eckstein 1.32  export PEGASUS_ROOT=%PEGASUS_RPM_ROOT
205                       export PEGASUS_HOME=%PEGASUS_RPM_HOME
206                       export PEGASUS_PLATFORM=%PEGASUS_HARDWARE_PLATFORM
207 denise.eckstein 1.74  export PEGASUS_ARCH_LIB=%PEGASUS_ARCH_LIB
208 denise.eckstein 1.32  export PEGASUS_ENVVAR_FILE=$PEGASUS_ROOT/env_var_Linux.status
209 w.otsuka        1.1   
210 denise.eckstein 1.32  export OPENSSL_HOME=%OPENSSL_HOME
211                       export OPENSSL_BIN=%OPENSSL_BIN
212                       export LD_LIBRARY_PATH=$PEGASUS_HOME/lib
213                       export PATH=$PEGASUS_HOME/bin:$PATH
214 w.otsuka        1.1   
215 denise.eckstein 1.97  export PEGASUS_EXTRA_C_FLAGS="$RPM_OPT_FLAGS -g -Wno-unused"
216 denise.eckstein 1.32  export PEGASUS_EXTRA_CXX_FLAGS="$PEGASUS_EXTRA_C_FLAGS"
217 denise.eckstein 1.74  export PEGASUS_EXTRA_LINK_FLAGS="$RPM_OPT_FLAGS"
218                       #export PEGASUS_EXTRA_LINK_FLAGS="$RPM_OPT_FLAGS -g -pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack"
219 w.otsuka        1.1   
220 w.otsuka        1.87  %if %{PEGASUS_BUILD_TEST_RPM}
221 yi.zhou         1.111 export PEGASUS_TMP=/usr/share/Pegasus/test/tmp
222                       export PEGASUS_DISPLAYCONSUMER_DIR="$PEGASUS_TMP"
223 w.otsuka        1.87  %endif
224                       
225 s.kodali        1.121 %if %{JMPI_PROVIDER_REQUESTED}
226                       sed -i 's/PEGASUS_ENABLE_JMPI_PROVIDER_MANAGER=.*$/PEGASUS_ENABLE_JMPI_PROVIDER_MANAGER=true/' $PEGASUS_ENVVAR_FILE
227                       %else
228                       sed -i 's/PEGASUS_ENABLE_JMPI_PROVIDER_MANAGER=.*$/PEGASUS_ENABLE_JMPI_PROVIDER_MANAGER=false/' $PEGASUS_ENVVAR_FILE
229                       %endif
230                       
231 denise.eckstein 1.32  make -f $PEGASUS_ROOT/Makefile.Release create_ProductVersionFile
232 denise.eckstein 1.76  make -f $PEGASUS_ROOT/Makefile.Release create_CommonProductDirectoriesInclude
233                       make -f $PEGASUS_ROOT/Makefile.Release create_ConfigProductDirectoriesInclude
234 w.otsuka        1.92  make %{?_smp_mflags} -f $PEGASUS_ROOT/Makefile.Release all
235 yi.zhou         1.98  chmod 777 %PEGASUS_RPM_HOME
236 denise.eckstein 1.32  make -f $PEGASUS_ROOT/Makefile.Release repository
237 denise.eckstein 1.74  #
238 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-build.spec
239 w.otsuka        1.27  
240 denise.eckstein 1.32  %install
241                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-install.spec
242 denise.eckstein 1.74  #
243 denise.eckstein 1.32  export PEGASUS_ROOT=%PEGASUS_RPM_ROOT
244                       export PEGASUS_HOME=%PEGASUS_RPM_HOME
245                       export PEGASUS_PLATFORM=%PEGASUS_HARDWARE_PLATFORM
246 denise.eckstein 1.74  export PEGASUS_ARCH_LIB=%PEGASUS_ARCH_LIB
247 denise.eckstein 1.32  export PEGASUS_ENVVAR_FILE=$PEGASUS_ROOT/env_var_Linux.status
248 w.otsuka        1.1   
249 denise.eckstein 1.32  export OPENSSL_BIN=%OPENSSL_BIN
250                       export LD_LIBRARY_PATH=$PEGASUS_HOME/lib
251                       export PATH=$PEGASUS_HOME/bin:$PATH
252 w.otsuka        1.1   
253 denise.eckstein 1.32  export PEGASUS_STAGING_DIR=$RPM_BUILD_ROOT
254 w.otsuka        1.1   
255 w.otsuka        1.56  %if %{PEGASUS_BUILD_TEST_RPM}
256 denise.eckstein 1.74  make -f $PEGASUS_ROOT/Makefile.Release stage \
257                           PEGASUS_STAGING_DIR=$PEGASUS_STAGING_DIR \
258                           PEGASUS_BUILD_TEST_RPM=%{PEGASUS_BUILD_TEST_RPM}
259 w.otsuka        1.56  %else
260 denise.eckstein 1.74  make -f $PEGASUS_ROOT/Makefile.Release stage \
261                           PEGASUS_STAGING_DIR=$PEGASUS_STAGING_DIR
262 w.otsuka        1.56  %endif
263 denise.eckstein 1.74  
264                       [ "$PEGASUS_HOME" != "/" ] && [ -d $PEGASUS_HOME ] && rm -rf $PEGASUS_HOME;
265                       #
266 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-install.spec
267 w.otsuka        1.1   
268 denise.eckstein 1.32  %clean
269                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-clean.spec
270 denise.eckstein 1.74  #
271 w.otsuka        1.77  [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT;
272                       [ "${RPM_BUILD_DIR}" != "/" ] && rm -rf ${RPM_BUILD_DIR}/%{name}-%{version};
273 denise.eckstein 1.74  #
274 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-clean.spec
275 w.otsuka        1.1   
276                       %pre
277 denise.eckstein 1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec
278                       #           install   remove   upgrade  reinstall
279                       # pre          1        -         2         2
280                       #
281                       # If it exists, the active OpenPegasus Repository
282                       #    directory, %PEGASUS_REPOSITORY_DIR is renamed
283                       #    to %PEGASUS_PREV_REPOSITORY_DIR.  If
284                       #    %PEGASUS_PREV_REPOSITORY_DIR already exists,
285                       #    it is saved as an archive file.
286 denise.eckstein 1.32  
287 denise.eckstein 1.74  if [ -d %PEGASUS_REPOSITORY_DIR"/root#PG_Internal" ]; then
288                          #
289                          # Save the current repository to prev_repository
290                          #
291                          if [ -d %PEGASUS_PREV_REPOSITORY_DIR ]; then
292                               /bin/tar -C %PEGASUS_REPOSITORY_PARENT_DIR -cf \
293                                   %PEGASUS_PREV_REPOSITORY_DIR`date '+%Y-%m-%d-%s.%N'`.tar \
294                                   %PEGASUS_PREV_REPOSITORY_DIR_NAME
295                               rm -rf %PEGASUS_PREV_REPOSITORY_DIR
296                          fi
297                          /bin/mv %PEGASUS_REPOSITORY_DIR %PEGASUS_PREV_REPOSITORY_DIR
298                       fi
299 w.otsuka        1.82  if [ $1 -gt 0 ]; then
300 denise.eckstein 1.74     #  Create the 'pegasus' user and group:
301                          /usr/sbin/groupadd pegasus > /dev/null 2>&1 || :;
302                          /usr/sbin/useradd -c "tog-pegasus OpenPegasus WBEM/CIM services" \
303                               -g pegasus -s /sbin/nologin -r -d %PEGASUS_VARDATA_DIR pegasus \
304                                > /dev/null 2>&1 || :;
305 w.otsuka        1.1   fi
306 yi.zhou         1.98  if [ $1 -eq 2 ]; then
307                           rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
308                           rm -f %PEGASUS_CIMSERVER_START_FILE;
309 yi.zhou         1.105     rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
310 yi.zhou         1.98  fi
311 denise.eckstein 1.74  #
312 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec
313 w.otsuka        1.1   
314 kumpf           1.119 # When Privilege Separation is enabled, create the 'cimsrvr' user and
315 denise.eckstein 1.100 # 'cimsrvr' group which are used as the context of the cimservermain process
316 yi.zhou         1.98  if [ $1 -gt 0 ]; then
317 denise.eckstein 1.100     /usr/sbin/groupadd cimsrvr > /dev/null 2>&1 || :;
318 yi.zhou         1.98      /usr/sbin/useradd -c "tog-pegasus OpenPegasus WBEM/CIM services" \
319 denise.eckstein 1.100         -g cimsrvr -s /sbin/nologin -r -d %PEGASUS_VARDATA_DIR cimsrvr \
320 yi.zhou         1.98          > /dev/null 2>&1 || :;
321                       fi
322                       
323 w.otsuka        1.1   %post
324 w.otsuka        1.24  if [ $1 -eq 1 ]; then
325 denise.eckstein 1.35     echo `date` > %PEGASUS_INSTALL_LOG 2>&1
326 denise.eckstein 1.76     %define PEGASUS_CONFIG_DIR /etc/Pegasus
327                          %define PEGASUS_PEM_DIR /etc/Pegasus
328 denise.eckstein 1.32     %define PEGASUS_SSL_CERT_FILE server.pem
329                          %define PEGASUS_SSL_KEY_FILE file.pem
330                          %define PEGASUS_SSL_TRUSTSTORE client.pem
331                       
332                          # Create Symbolic Links for SDK Libraries
333                          #
334 denise.eckstein 1.81     ln -sf libpegclient.so.1 /usr/%PEGASUS_ARCH_LIB/libpegclient.so
335                          ln -sf libpegcommon.so.1 /usr/%PEGASUS_ARCH_LIB/libpegcommon.so
336                          ln -sf libpegprovider.so.1 /usr/%PEGASUS_ARCH_LIB/libpegprovider.so
337                          ln -sf libDefaultProviderManager.so.1 /usr/%PEGASUS_ARCH_LIB/libDefaultProviderManager.so
338                          ln -sf libCIMxmlIndicationHandler.so.1 /usr/%PEGASUS_ARCH_LIB/libCIMxmlIndicationHandler.so
339 yi.zhou         1.93     ln -sf libsnmpIndicationHandler.so.1 /usr/%PEGASUS_ARCH_LIB/libsnmpIndicationHandler.so
340 denise.eckstein 1.32  
341                          # Create Symbolic Links for Packaged Provider Libraries
342                          #
343 denise.eckstein 1.81     ln -sf libComputerSystemProvider.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libComputerSystemProvider.so
344                          ln -sf libOSProvider.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libOSProvider.so
345                          ln -sf libProcessProvider.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libProcessProvider.so
346 denise.eckstein 1.32  
347 denise.eckstein 1.110    # Create Symbolic Links for Packaged Provider Managers
348                          #
349                          ln -sf libCMPIProviderManager.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers/libCMPIProviderManager.so
350                       
351 denise.eckstein 1.32  
352                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-post.spec
353 denise.eckstein 1.74  #
354                       #           install   remove   upgrade  reinstall
355                       # %post        1        -         2         2
356                       #
357 denise.eckstein 1.81     export PEGASUS_ARCH_LIB=%PEGASUS_ARCH_LIB
358                       
359 denise.eckstein 1.74     if [ $1 -eq 1 ]; then
360                       %if %{AUTOSTART}
361                              /sbin/chkconfig --add tog-pegasus
362                       %endif
363                          :;
364                          elif [ $1 -gt 0 ]; then
365 w.otsuka        1.79         /etc/init.d/tog-pegasus condrestart
366 denise.eckstein 1.74     :;
367 denise.eckstein 1.32     fi
368 denise.eckstein 1.74  #
369 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-post.spec
370 w.otsuka        1.1   
371 w.otsuka        1.57  elif [ $1 -gt 1 ]; then
372 yi.zhou         1.98     # Check if the cimserver is running
373                          isRunning=`ps -el | grep cimserver | grep -v "grep cimserver"`
374                          if [ "$isRunning" ]; then
375                              /etc/init.d/tog-pegasus stop
376                          fi
377 sushma.fernandes 1.104    if [ -d %PEGASUS_PREV_REPOSITORY_DIR ]; then
378                               # The old repository was moved to /var/lib/Pegasus/prev_repository. It should now be upgraded to the new repository /var/lib/Pegasus/repository.
379                               %PEGASUS_SBIN_DIR/repupgrade >> %PEGASUS_INSTALL_LOG 2>&1
380                               chown -R cimsrvr %PEGASUS_REPOSITORY_DIR
381                               chgrp -R cimsrvr %PEGASUS_REPOSITORY_DIR
382                           fi
383 yi.zhou          1.98     if [ -f %PEGASUS_TRACE_FILE_PATH ]; then
384                             /bin/mv %PEGASUS_TRACE_FILE_PATH %PEGASUS_TRACE_FILE_PATH-`date '+%Y-%m-%d-%R'`
385                           fi
386                           if [ "$isRunning" ]; then
387                               /etc/init.d/tog-pegasus start
388                           fi
389 w.otsuka         1.24  fi
390 denise.eckstein  1.74  
391 w.otsuka         1.1   %preun
392 denise.eckstein  1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
393                        #           install   remove   upgrade  reinstall
394                        #  preun       -        0         1         -
395 w.otsuka         1.24  if [ $1 -eq 0 ]; then
396 denise.eckstein  1.32     # Check if the cimserver is running
397 denise.eckstein  1.74     isRunning=`ps -el | grep cimserver |  grep -v "grep cimserver"`
398 denise.eckstein  1.32     if [ "$isRunning" ]; then
399 denise.eckstein  1.74        %PEGASUS_SBIN_DIR/cimserver -s
400 kumpf            1.119    fi
401 denise.eckstein  1.74     /sbin/chkconfig --del tog-pegasus;
402                           rm -f %PEGASUS_VARDATA_DIR/cimserver_current.conf;
403                           [ -d %PEGASUS_REPOSITORY_DIR ]  && rm -rf %PEGASUS_REPOSITORY_DIR;
404                           [ -d %PEGASUS_VARDATA_CACHE_DIR ]  && rm -rf %PEGASUS_VARDATA_CACHE_DIR;
405                           rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
406                           rm -f %PEGASUS_CIMSERVER_START_FILE;
407 kumpf            1.94     rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
408 w.otsuka         1.24  fi
409 denise.eckstein  1.74  #
410                        # End of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
411 w.otsuka         1.1   
412 w.otsuka         1.69  %preun devel
413 yi.zhou          1.106 # Check if the SDK has been setup
414                        if [ -f /usr/share/Pegasus/samples/SDKIsSetup ]; then
415                           make --directory /usr/share/Pegasus/samples -s unsetupSDK
416                           if [ $? != 0 ]; then
417                              echo "++++++++++++++++++++++++++++++++++++++++++++++" >&2
418                              echo "ERROR: Failed to deregister sample providers." >&2
419                              echo "To remove the SDK rpm without deregistering" >&2
420                              echo "the sample providers, first remove file" >&2
421                              echo "/usr/share/Pegasus/samples/SDKIsSetup," >&2
422                              echo "then remove SDK rpm." >&2
423                              echo "++++++++++++++++++++++++++++++++++++++++++++++" >&2
424                              exit 1
425                           fi
426                        fi
427 denise.eckstein  1.76  make --directory /usr/share/Pegasus/samples -s clean
428 denise.eckstein  1.44  
429 w.otsuka         1.56  %if %{PEGASUS_BUILD_TEST_RPM}
430 denise.eckstein  1.46  %preun test
431 denise.eckstein  1.76  make --directory /usr/share/Pegasus/test -s unsetupTEST
432                        [ -d /var/lib/Pegasus/testrepository ] &&  rm -rf /var/lib/Pegasus/testrepository;
433 denise.eckstein  1.46  
434 w.otsuka         1.56  %endif
435 w.otsuka         1.1   %postun
436 w.otsuka         1.24  if [ $1 -eq 0 ]; then
437 denise.eckstein  1.32     export LC_ALL=C
438 w.otsuka         1.1   fi
439 denise.eckstein  1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-postun.spec
440                        #
441                        #           install   remove   upgrade  reinstall
442                        #  postun      -        0         1         -
443                        if [ $1 -eq 0 ]; then
444                           /usr/sbin/userdel pegasus > /dev/null 2>&1 || :;
445 w.otsuka         1.78     /usr/sbin/groupdel pegasus > /dev/null 2>&1 || :;
446 denise.eckstein  1.74  fi;
447                        #
448                        # End of section pegasus/rpm/tog-specfiles/tog-pegasus-postun.spec
449 w.otsuka         1.1   
450 kumpf            1.119 # When Privilege Separation is enabled, delete the 'cimsrvr' user and
451 denise.eckstein  1.100 # 'cimsrvr' group which are used as the context of the cimservermain process
452 yi.zhou          1.98  if [ $1 -eq 0 ]; then
453                            /usr/sbin/userdel cimsrvr > /dev/null 2>&1 || :;
454 denise.eckstein  1.100     /usr/sbin/groupdel cimsrvr > /dev/null 2>&1 || :;
455 yi.zhou          1.98  fi
456                        
457 w.otsuka         1.1   %files
458 denise.eckstein  1.109 %defattr(600,cimsrvr,cimsrvr,700)
459 yi.zhou          1.98  /var/lib/Pegasus/repository
460 denise.eckstein  1.109 
461                        %defattr(644,root,pegasus,755)
462                        /usr/share/Pegasus/mof
463                        
464                        %defattr(600,root,pegasus,755)
465 denise.eckstein  1.120 %dir /usr/share/doc/tog-pegasus-2.10
466 denise.eckstein  1.76  %dir /usr/share/Pegasus
467                        %dir /usr/share/Pegasus/scripts
468                        %dir /var/lib/Pegasus
469                        %dir /var/lib/Pegasus/cache
470                        %dir /var/lib/Pegasus/log
471                        %dir /var/lib/Pegasus/cache/localauth
472 kumpf            1.119 %dir /usr/%PEGASUS_ARCH_LIB/Pegasus
473                        %dir /usr/%PEGASUS_ARCH_LIB/Pegasus/providers
474                        %dir /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers
475 denise.eckstein  1.74  
476 denise.eckstein  1.109 %dir %attr(755,root,pegasus) /etc/Pegasus
477                        %dir %attr(755,cimsrvr,cimsrvr) /var/run/tog-pegasus
478 denise.eckstein  1.100 %dir %attr(1755,cimsrvr,cimsrvr) /var/run/tog-pegasus/socket
479 denise.eckstein  1.76  %dir %attr(1777,root,pegasus) /var/lib/Pegasus/cache/trace
480 denise.eckstein  1.74  
481                        %config %attr(750,root,pegasus) /etc/init.d/tog-pegasus
482 denise.eckstein  1.108 %config(noreplace) %attr(644,root,root) /var/lib/Pegasus/cimserver_planned.conf
483 denise.eckstein  1.76  %config(noreplace) /etc/Pegasus/access.conf
484 denise.eckstein  1.74  %config(noreplace) /etc/pam.d/wbem
485                        
486 denise.eckstein  1.76  %ghost %config(noreplace) /etc/Pegasus/ssl.cnf
487                        %ghost %config(noreplace) /etc/Pegasus/client.pem
488                        %ghost %config(noreplace) /etc/Pegasus/server.pem
489                        %ghost %config(noreplace) /etc/Pegasus/file.pem
490                        %ghost /var/lib/Pegasus/log/install.log
491                        
492 denise.eckstein  1.99  %attr(755,root,pegasus) /usr/sbin/*
493 denise.eckstein  1.76  %attr(755,root,pegasus) /usr/bin/*
494 denise.eckstein  1.81  %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/*.so.1
495 s.kodali         1.121 %if %{JMPI_PROVIDER_REQUESTED}
496                        %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/*.jar
497                        /usr/%PEGASUS_ARCH_LIB/libJMPIProviderManager.so
498                        %endif
499 denise.eckstein  1.81  %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/*.so.1
500 denise.eckstein  1.110 %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers/*.so.1
501 denise.eckstein  1.76  %attr(750,root,pegasus) /usr/share/Pegasus/scripts/*
502                        %attr(644,root,pegasus) /usr/share/man/man1/*
503 denise.eckstein  1.101 %attr(644,root,pegasus) /usr/share/man/man8/*
504 denise.eckstein  1.76  
505 denise.eckstein  1.120 %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.10/Admin_Guide_Release.pdf
506                        %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.10/PegasusSSLGuidelines.htm
507                        %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.10/license.txt
508                        %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.10/OpenPegasusNOTICE.txt
509 denise.eckstein  1.81  /usr/%PEGASUS_ARCH_LIB/libpegclient.so
510                        /usr/%PEGASUS_ARCH_LIB/libpegcommon.so
511                        /usr/%PEGASUS_ARCH_LIB/libpegprovider.so
512                        /usr/%PEGASUS_ARCH_LIB/libDefaultProviderManager.so
513                        /usr/%PEGASUS_ARCH_LIB/libCIMxmlIndicationHandler.so
514 yi.zhou          1.93  /usr/%PEGASUS_ARCH_LIB/libsnmpIndicationHandler.so
515 denise.eckstein  1.81  /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libComputerSystemProvider.so
516                        /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libOSProvider.so
517                        /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libProcessProvider.so
518 denise.eckstein  1.110 /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers/libCMPIProviderManager.so
519 w.otsuka         1.1   
520 w.otsuka         1.69  %files devel
521 denise.eckstein  1.76  %defattr(644,root,pegasus,755)
522 denise.eckstein  1.89  /usr/share/Pegasus/samples
523 w.otsuka         1.80  /usr/include/Pegasus
524 denise.eckstein  1.120 %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.10/SecurityGuidelinesForDevelopers.html
525 denise.eckstein  1.76  /usr/share/Pegasus/html
526 w.otsuka         1.28  
527 w.otsuka         1.56  %if %{PEGASUS_BUILD_TEST_RPM}
528 w.otsuka         1.28  %files test
529 denise.eckstein  1.74  %defattr(-,root,pegasus,-)
530 denise.eckstein  1.114 
531                        %dir /usr/share/Pegasus/test
532                        %dir /usr/share/Pegasus/test/bin
533                        %dir /usr/share/Pegasus/test/%PEGASUS_ARCH_LIB
534                        %dir /usr/share/Pegasus/test/mak
535                        %dir /usr/share/Pegasus/test/tmp
536                        
537 yi.zhou          1.111 %ghost /usr/share/Pegasus/test/tmp/procIdFile
538                        %ghost /usr/share/Pegasus/test/tmp/trapLogFile
539                        %ghost /usr/share/Pegasus/test/tmp/IndicationStressTestLog
540 denise.eckstein  1.114 %ghost /usr/share/Pegasus/test/tmp/oldIndicationStressTestLog
541                        
542                        %attr(744,root,pegasus) /usr/share/Pegasus/test/bin/*
543                        %attr(744,root,pegasus) /usr/share/Pegasus/test/%PEGASUS_ARCH_LIB/*
544                        %attr(744,root,pegasus) /usr/share/Pegasus/test/mak/*
545                        %attr(644,root,pegasus) /usr/share/Pegasus/test/Makefile
546                        
547 denise.eckstein  1.100 %defattr(600,cimsrvr, cimsrvr,700)
548 denise.eckstein  1.76  /var/lib/Pegasus/testrepository
549 w.otsuka         1.56  %endif

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2