(file) Return to tog-pegasus.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm

  1 karl  1.84 #//%2006////////////////////////////////////////////////////////////////////////
  2            #//
  3            #// Copyright (c) 2000, 2001, 2002 BMC Software; Hewlett-Packard Development
  4            #// Company, L.P.; IBM Corp.; The Open Group; Tivoli Systems.
  5            #// Copyright (c) 2003 BMC Software; Hewlett-Packard Development Company, L.P.;
  6            #// IBM Corp.; EMC Corporation, The Open Group.
  7            #// Copyright (c) 2004 BMC Software; Hewlett-Packard Development Company, L.P.;
  8            #// IBM Corp.; EMC Corporation; VERITAS Software Corporation; The Open Group.
  9            #// Copyright (c) 2005 Hewlett-Packard Development Company, L.P.; IBM Corp.;
 10            #// EMC Corporation; VERITAS Software Corporation; The Open Group.
 11            #// Copyright (c) 2006 Hewlett-Packard Development Company, L.P.; IBM Corp.;
 12            #// EMC Corporation; Symantec Corporation; The Open Group.
 13            #//
 14            #// Permission is hereby granted, free of charge, to any person obtaining a copy
 15            #// of this software and associated documentation files (the "Software"), to
 16            #// deal in the Software without restriction, including without limitation the
 17            #// rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
 18            #// sell copies of the Software, and to permit persons to whom the Software is
 19            #// furnished to do so, subject to the following conditions:
 20            #// 
 21            #// THE ABOVE COPYRIGHT NOTICE AND THIS PERMISSION NOTICE SHALL BE INCLUDED IN
 22 karl  1.84 #// ALL COPIES OR SUBSTANTIAL PORTIONS OF THE SOFTWARE. THE SOFTWARE IS PROVIDED
 23            #// "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
 24            #// LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
 25            #// PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
 26            #// HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
 27            #// ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
 28            #// WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
 29            #//
 30            #//==============================================================================
 31 w.otsuka 1.1  #%/////////////////////////////////////////////////////////////////////////////
 32               #
 33               # tog-pegasus.spec
 34               #
 35 denise.eckstein 1.32 #%/////////////////////////////////////////////////////////////////////////////
 36                      
 37                      #
 38                      # WARNING: This file is automatically generated by executing 
 39                      #   make -f pegasus/Makefile.Release create_OpenPegasusRPMSpecFile
 40 denise.eckstein 1.74 # Any changes made directly to this file in the OpenPegasus source will
 41                      # be lost the next time this file is regenerated and submitted to CVS.
 42 w.otsuka        1.1  #
 43 denise.eckstein 1.32 
 44 dave.sudlik     1.107 %define packageVersion 1
 45 denise.eckstein 1.113 Version: 2.9.0
 46 denise.eckstein 1.102 Release: %{packageVersion}%{?LINUX_VERSION:.%{LINUX_VERSION}}
 47 w.otsuka        1.56  Epoch:   1
 48 denise.eckstein 1.32  
 49                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-intro.spec
 50 denise.eckstein 1.74  #
 51 w.otsuka        1.56  %{?!PEGASUS_BUILD_TEST_RPM:   %define PEGASUS_BUILD_TEST_RPM        0}
 52 denise.eckstein 1.74  # do "rpmbuild --define 'PEGASUS_BUILD_TEST_RPM 1'" to build test RPM.
 53                       #
 54                       %{?!AUTOSTART:   %define AUTOSTART        0}
 55                       # Use "rpm -[iU]vh --define 'AUTOSTART 1'" in order to have cimserver enabled
 56                       # (chkconfig --level=345 tog-pegasus on) after installation.
 57                       #
 58                       
 59                       Summary:   OpenPegasus WBEM Services for Linux
 60                       Name:      tog-pegasus
 61                       Group:     Systems Management/Base
 62                       License:   Open Group Pegasus Open Source
 63                       BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 64                       URL:       http://www.openpegasus.org
 65                       
 66 denise.eckstein 1.102 Source:    %{name}-%{version}-%{packageVersion}.tar.gz
 67 yi.zhou         1.93  #
 68                       # End of section pegasus/rpm/tog-specfiles/tog-pegasus-intro.spec
 69 denise.eckstein 1.74  
 70 yi.zhou         1.93  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-buildRequires.spec
 71                       #
 72 denise.eckstein 1.74  BuildRequires:      bash, sed, grep, coreutils, procps, gcc, gcc-c++
 73                       BuildRequires:      libstdc++, make, pam-devel
 74                       BuildRequires:      openssl-devel >= 0.9.6, e2fsprogs
 75 yi.zhou         1.93  BuildRequires:      net-snmp-devel
 76                       #
 77                       # End of section  pegasus/rpm/tog-specfiles/tog-pegasus-buildRequires.spec
 78                       
 79                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-requires.spec
 80                       #
 81 denise.eckstein 1.74  Requires:           bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 82                       #Requires:          krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 83                       Requires:           e2fsprogs, bind-utils, net-tools
 84                       Requires(post):     bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 85                       #Requires(post):    krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 86                       Requires(post):     e2fsprogs, bind-utils, net-tools
 87                       Requires(pre):      bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 88                       #Requires(pre):     krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 89                       Requires(pre):      e2fsprogs, bind-utils, net-tools
 90                       Requires(postun):   bash, sed, grep, coreutils, procps, openssl >= 0.9.6, pam
 91                       #Requires(postun):  krb5-libs, redhat-lsb, chkconfig, SysVinit, bind-libs
 92                       Requires(postun):   e2fsprogs, bind-utils, net-tools
 93 yi.zhou         1.93  Requires:           net-snmp
 94                       #
 95                       # End of section  pegasus/rpm/tog-specfiles/tog-pegasus-requires.spec
 96 denise.eckstein 1.74  
 97 yi.zhou         1.93  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-desc.spec
 98                       #
 99 w.otsuka        1.73  Conflicts: openwbem
100 denise.eckstein 1.32  Provides: tog-pegasus-cimserver
101 w.otsuka        1.64  BuildConflicts: tog-pegasus
102 w.otsuka        1.1   
103                       %description
104 w.otsuka        1.9   OpenPegasus WBEM Services for Linux enables management solutions that deliver
105 w.otsuka        1.1   increased control of enterprise resources. WBEM is a platform and resource
106                       independent DMTF standard that defines a common information model and
107                       communication protocol for monitoring and controlling resources from diverse
108                       sources.
109 denise.eckstein 1.74  #
110 yi.zhou         1.93  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-desc.spec
111 w.otsuka        1.1   
112 denise.eckstein 1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-arch.spec
113                       #
114 w.otsuka        1.54  %ifarch ia64
115 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_IA64_GNU
116 w.otsuka        1.1   %else
117 w.otsuka        1.54  %ifarch x86_64
118                       %global PEGASUS_HARDWARE_PLATFORM LINUX_X86_64_GNU
119                       %else
120 w.otsuka        1.24  %ifarch ppc
121 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_PPC_GNU
122 w.otsuka        1.24  %else
123 denise.eckstein 1.44  %ifarch ppc64 pseries
124 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_PPC64_GNU
125 w.otsuka        1.24  %else
126                       %ifarch s390
127 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_ZSERIES_GNU
128 w.otsuka        1.24  %else
129                       %ifarch s390x zseries
130 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_ZSERIES64_GNU
131 w.otsuka        1.24  %else
132 denise.eckstein 1.32  %global PEGASUS_HARDWARE_PLATFORM LINUX_IX86_GNU
133 denise.eckstein 1.74  %endif 
134                       %endif 
135                       %endif 
136                       %endif 
137 w.otsuka        1.1   %endif
138 w.otsuka        1.24  %endif
139 denise.eckstein 1.74  #
140                       # End of section pegasus/rpm/tog-specfiles/tog-pegasus-arch.spec
141 w.otsuka        1.55  
142 denise.eckstein 1.81  %global PEGASUS_ARCH_LIB %{_lib}
143 w.otsuka        1.86  %global OPENSSL_HOME /usr
144 denise.eckstein 1.81  %global OPENSSL_BIN /usr/bin
145                       %global PEGASUS_PEM_DIR /etc/Pegasus
146                       %global PEGASUS_SSL_CERT_FILE server.pem
147                       %global PEGASUS_SSL_KEY_FILE file.pem
148                       %global PEGASUS_SSL_TRUSTSTORE client.pem
149                       %global PAM_CONFIG_DIR /etc/pam.d
150                       %global PEGASUS_CONFIG_DIR /etc/Pegasus
151                       %global PEGASUS_VARDATA_DIR /var/lib/Pegasus
152                       %global PEGASUS_VARDATA_CACHE_DIR /var/lib/Pegasus/cache
153                       %global PEGASUS_LOCAL_DOMAIN_SOCKET_PATH  /var/run/tog-pegasus/socket/cimxml.socket
154                       %global PEGASUS_CIMSERVER_START_FILE /var/run/tog-pegasus/cimserver.pid
155 yi.zhou         1.98  %global PEGASUS_TRACE_FILE_PATH /var/lib/Pegasus/cache/trace/cimserver.trc
156 kumpf           1.94  %global PEGASUS_CIMSERVER_START_LOCK_FILE /var/run/tog-pegasus/cimserver_start.lock
157 denise.eckstein 1.81  %global PEGASUS_REPOSITORY_DIR /var/lib/Pegasus/repository
158                       %global PEGASUS_PREV_REPOSITORY_DIR_NAME prev_repository
159                       %global PEGASUS_REPOSITORY_PARENT_DIR /var/lib/Pegasus
160                       %global PEGASUS_PREV_REPOSITORY_DIR /var/lib/Pegasus/prev_repository
161                       %global PEGASUS_SBIN_DIR /usr/sbin
162 denise.eckstein 1.113 %global PEGASUS_DOC_DIR /usr/share/doc/tog-pegasus-2.9
163 denise.eckstein 1.81  
164                       %global PEGASUS_RPM_ROOT  $RPM_BUILD_DIR/$RPM_PACKAGE_NAME-$RPM_PACKAGE_VERSION
165 denise.eckstein 1.95  %global PEGASUS_RPM_HOME %PEGASUS_RPM_ROOT/build
166 denise.eckstein 1.81  %global PEGASUS_INSTALL_LOG /var/lib/Pegasus/log/install.log
167                       
168 denise.eckstein 1.32  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-packages.spec
169 denise.eckstein 1.74  #
170 w.otsuka        1.69  %package devel
171 denise.eckstein 1.32  Summary: The OpenPegasus Software Development Kit
172                       Group: Systems Management/Base
173                       Requires: tog-pegasus >= %{version}
174 w.otsuka        1.69  Obsoletes: tog-pegasus-sdk
175 w.otsuka        1.1   
176 w.otsuka        1.69  %description devel
177 denise.eckstein 1.74  The OpenPegasus WBEM Services for Linux SDK is the developer's kit for the
178                       OpenPegasus WBEM Services for Linux release. It provides Linux C++ developers
179                       with the WBEM files required to build WBEM Clients and Providers. It also
180                       supports C provider developers via the CMPI interface.
181 w.otsuka        1.1   
182 w.otsuka        1.56  %if %{PEGASUS_BUILD_TEST_RPM}
183 denise.eckstein 1.32  %package test
184                       Summary: The OpenPegasus Tests
185                       Group: Systems Management/Base
186                       Requires: tog-pegasus >= %{version} 
187 w.otsuka        1.1   
188 denise.eckstein 1.32  %description test
189                       The OpenPegasus WBEM tests for the OpenPegasus %{version} Linux rpm.
190 w.otsuka        1.56  %endif
191 denise.eckstein 1.74  #
192                       #End of section pegasus/rpm/tog-specfiles/tog-pegasus-packages.spec
193 w.otsuka        1.1   
194 denise.eckstein 1.32  %prep
195 denise.eckstein 1.74  %setup -q -n %{name}-%{version}
196 w.otsuka        1.28  
197 denise.eckstein 1.32  %build
198                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-build.spec
199 denise.eckstein 1.74  #
200 denise.eckstein 1.32  export PEGASUS_ROOT=%PEGASUS_RPM_ROOT
201                       export PEGASUS_HOME=%PEGASUS_RPM_HOME
202                       export PEGASUS_PLATFORM=%PEGASUS_HARDWARE_PLATFORM
203 denise.eckstein 1.74  export PEGASUS_ARCH_LIB=%PEGASUS_ARCH_LIB
204 denise.eckstein 1.32  export PEGASUS_ENVVAR_FILE=$PEGASUS_ROOT/env_var_Linux.status
205 w.otsuka        1.1   
206 denise.eckstein 1.32  export OPENSSL_HOME=%OPENSSL_HOME
207                       export OPENSSL_BIN=%OPENSSL_BIN
208                       export LD_LIBRARY_PATH=$PEGASUS_HOME/lib
209                       export PATH=$PEGASUS_HOME/bin:$PATH
210 w.otsuka        1.1   
211 denise.eckstein 1.97  export PEGASUS_EXTRA_C_FLAGS="$RPM_OPT_FLAGS -g -Wno-unused"
212 denise.eckstein 1.32  export PEGASUS_EXTRA_CXX_FLAGS="$PEGASUS_EXTRA_C_FLAGS"
213 denise.eckstein 1.74  export PEGASUS_EXTRA_LINK_FLAGS="$RPM_OPT_FLAGS"
214                       #export PEGASUS_EXTRA_LINK_FLAGS="$RPM_OPT_FLAGS -g -pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack"
215 w.otsuka        1.1   
216 w.otsuka        1.87  %if %{PEGASUS_BUILD_TEST_RPM}
217 yi.zhou         1.111 export PEGASUS_TMP=/usr/share/Pegasus/test/tmp
218                       export PEGASUS_DISPLAYCONSUMER_DIR="$PEGASUS_TMP"
219 w.otsuka        1.87  %endif
220                       
221 denise.eckstein 1.32  make -f $PEGASUS_ROOT/Makefile.Release create_ProductVersionFile
222 denise.eckstein 1.76  make -f $PEGASUS_ROOT/Makefile.Release create_CommonProductDirectoriesInclude
223                       make -f $PEGASUS_ROOT/Makefile.Release create_ConfigProductDirectoriesInclude
224 w.otsuka        1.92  make %{?_smp_mflags} -f $PEGASUS_ROOT/Makefile.Release all
225 yi.zhou         1.98  chmod 777 %PEGASUS_RPM_HOME
226 denise.eckstein 1.32  make -f $PEGASUS_ROOT/Makefile.Release repository
227 denise.eckstein 1.74  #
228 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-build.spec
229 w.otsuka        1.27  
230 denise.eckstein 1.32  %install
231                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-install.spec
232 denise.eckstein 1.74  #
233 denise.eckstein 1.32  export PEGASUS_ROOT=%PEGASUS_RPM_ROOT
234                       export PEGASUS_HOME=%PEGASUS_RPM_HOME
235                       export PEGASUS_PLATFORM=%PEGASUS_HARDWARE_PLATFORM
236 denise.eckstein 1.74  export PEGASUS_ARCH_LIB=%PEGASUS_ARCH_LIB
237 denise.eckstein 1.32  export PEGASUS_ENVVAR_FILE=$PEGASUS_ROOT/env_var_Linux.status
238 w.otsuka        1.1   
239 denise.eckstein 1.32  export OPENSSL_BIN=%OPENSSL_BIN
240                       export LD_LIBRARY_PATH=$PEGASUS_HOME/lib
241                       export PATH=$PEGASUS_HOME/bin:$PATH
242 w.otsuka        1.1   
243 denise.eckstein 1.32  export PEGASUS_STAGING_DIR=$RPM_BUILD_ROOT
244 w.otsuka        1.1   
245 w.otsuka        1.56  %if %{PEGASUS_BUILD_TEST_RPM}
246 denise.eckstein 1.74  make -f $PEGASUS_ROOT/Makefile.Release stage \
247                           PEGASUS_STAGING_DIR=$PEGASUS_STAGING_DIR \
248                           PEGASUS_BUILD_TEST_RPM=%{PEGASUS_BUILD_TEST_RPM}
249 w.otsuka        1.56  %else
250 denise.eckstein 1.74  make -f $PEGASUS_ROOT/Makefile.Release stage \
251                           PEGASUS_STAGING_DIR=$PEGASUS_STAGING_DIR
252 w.otsuka        1.56  %endif
253 denise.eckstein 1.74  
254                       [ "$PEGASUS_HOME" != "/" ] && [ -d $PEGASUS_HOME ] && rm -rf $PEGASUS_HOME;
255                       #
256 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-install.spec
257 w.otsuka        1.1   
258 denise.eckstein 1.32  %clean
259                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-clean.spec
260 denise.eckstein 1.74  #
261 w.otsuka        1.77  [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT;
262                       [ "${RPM_BUILD_DIR}" != "/" ] && rm -rf ${RPM_BUILD_DIR}/%{name}-%{version};
263 denise.eckstein 1.74  #
264 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-clean.spec
265 w.otsuka        1.1   
266                       %pre
267 denise.eckstein 1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec
268                       #           install   remove   upgrade  reinstall
269                       # pre          1        -         2         2
270                       #
271                       # If it exists, the active OpenPegasus Repository
272                       #    directory, %PEGASUS_REPOSITORY_DIR is renamed
273                       #    to %PEGASUS_PREV_REPOSITORY_DIR.  If
274                       #    %PEGASUS_PREV_REPOSITORY_DIR already exists,
275                       #    it is saved as an archive file.
276 denise.eckstein 1.32  
277 denise.eckstein 1.74  if [ -d %PEGASUS_REPOSITORY_DIR"/root#PG_Internal" ]; then
278                          #
279                          # Save the current repository to prev_repository
280                          #
281                          if [ -d %PEGASUS_PREV_REPOSITORY_DIR ]; then
282                               /bin/tar -C %PEGASUS_REPOSITORY_PARENT_DIR -cf \
283                                   %PEGASUS_PREV_REPOSITORY_DIR`date '+%Y-%m-%d-%s.%N'`.tar \
284                                   %PEGASUS_PREV_REPOSITORY_DIR_NAME
285                               rm -rf %PEGASUS_PREV_REPOSITORY_DIR
286                          fi
287                          /bin/mv %PEGASUS_REPOSITORY_DIR %PEGASUS_PREV_REPOSITORY_DIR
288                       fi
289 w.otsuka        1.82  if [ $1 -gt 0 ]; then
290 denise.eckstein 1.74     #  Create the 'pegasus' user and group:
291                          /usr/sbin/groupadd pegasus > /dev/null 2>&1 || :;
292                          /usr/sbin/useradd -c "tog-pegasus OpenPegasus WBEM/CIM services" \
293                               -g pegasus -s /sbin/nologin -r -d %PEGASUS_VARDATA_DIR pegasus \
294                                > /dev/null 2>&1 || :;
295 w.otsuka        1.1   fi
296 yi.zhou         1.98  if [ $1 -eq 2 ]; then
297                           rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
298                           rm -f %PEGASUS_CIMSERVER_START_FILE;
299 yi.zhou         1.105     rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
300 yi.zhou         1.98  fi
301 denise.eckstein 1.74  #
302 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-pre.spec
303 w.otsuka        1.1   
304 yi.zhou         1.98  # When Privilege Separation is enabled, create the 'cimsrvr' user and 
305 denise.eckstein 1.100 # 'cimsrvr' group which are used as the context of the cimservermain process
306 yi.zhou         1.98  if [ $1 -gt 0 ]; then
307 denise.eckstein 1.100     /usr/sbin/groupadd cimsrvr > /dev/null 2>&1 || :;
308 yi.zhou         1.98      /usr/sbin/useradd -c "tog-pegasus OpenPegasus WBEM/CIM services" \
309 denise.eckstein 1.100         -g cimsrvr -s /sbin/nologin -r -d %PEGASUS_VARDATA_DIR cimsrvr \
310 yi.zhou         1.98          > /dev/null 2>&1 || :;
311                       fi
312                       
313 w.otsuka        1.1   %post
314 w.otsuka        1.24  if [ $1 -eq 1 ]; then
315 denise.eckstein 1.35     echo `date` > %PEGASUS_INSTALL_LOG 2>&1
316 denise.eckstein 1.76     %define PEGASUS_CONFIG_DIR /etc/Pegasus
317                          %define PEGASUS_PEM_DIR /etc/Pegasus
318 denise.eckstein 1.32     %define PEGASUS_SSL_CERT_FILE server.pem
319                          %define PEGASUS_SSL_KEY_FILE file.pem
320                          %define PEGASUS_SSL_TRUSTSTORE client.pem
321                       
322                          # Create Symbolic Links for SDK Libraries
323                          #
324 denise.eckstein 1.81     ln -sf libpegclient.so.1 /usr/%PEGASUS_ARCH_LIB/libpegclient.so
325                          ln -sf libpegcommon.so.1 /usr/%PEGASUS_ARCH_LIB/libpegcommon.so
326                          ln -sf libpegprovider.so.1 /usr/%PEGASUS_ARCH_LIB/libpegprovider.so
327                          ln -sf libDefaultProviderManager.so.1 /usr/%PEGASUS_ARCH_LIB/libDefaultProviderManager.so
328                          ln -sf libCIMxmlIndicationHandler.so.1 /usr/%PEGASUS_ARCH_LIB/libCIMxmlIndicationHandler.so
329 yi.zhou         1.93     ln -sf libsnmpIndicationHandler.so.1 /usr/%PEGASUS_ARCH_LIB/libsnmpIndicationHandler.so
330 denise.eckstein 1.32  
331                          # Create Symbolic Links for Packaged Provider Libraries
332                          #
333 denise.eckstein 1.81     ln -sf libComputerSystemProvider.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libComputerSystemProvider.so
334                          ln -sf libOSProvider.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libOSProvider.so
335                          ln -sf libProcessProvider.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libProcessProvider.so
336 denise.eckstein 1.32  
337 denise.eckstein 1.110    # Create Symbolic Links for Packaged Provider Managers
338                          #
339                          ln -sf libCMPIProviderManager.so.1 /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers/libCMPIProviderManager.so
340                       
341 denise.eckstein 1.32  
342                       # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-post.spec
343 denise.eckstein 1.74  #
344                       #           install   remove   upgrade  reinstall
345                       # %post        1        -         2         2
346                       #
347 denise.eckstein 1.81     export PEGASUS_ARCH_LIB=%PEGASUS_ARCH_LIB
348                       
349 denise.eckstein 1.74     if [ $1 -eq 1 ]; then
350                       %if %{AUTOSTART}
351                              /sbin/chkconfig --add tog-pegasus
352                       %endif
353                          :;
354                          elif [ $1 -gt 0 ]; then
355 w.otsuka        1.79         /etc/init.d/tog-pegasus condrestart
356 denise.eckstein 1.74     :;
357 denise.eckstein 1.32     fi
358 denise.eckstein 1.74  #
359 denise.eckstein 1.32  # End of section pegasus/rpm/tog-specfiles/tog-pegasus-post.spec
360 w.otsuka        1.1   
361 w.otsuka        1.57  elif [ $1 -gt 1 ]; then
362 yi.zhou         1.98     # Check if the cimserver is running
363                          isRunning=`ps -el | grep cimserver | grep -v "grep cimserver"`
364                          if [ "$isRunning" ]; then
365                              /etc/init.d/tog-pegasus stop
366                          fi
367 sushma.fernandes 1.104    if [ -d %PEGASUS_PREV_REPOSITORY_DIR ]; then
368                               # The old repository was moved to /var/lib/Pegasus/prev_repository. It should now be upgraded to the new repository /var/lib/Pegasus/repository.
369                               %PEGASUS_SBIN_DIR/repupgrade >> %PEGASUS_INSTALL_LOG 2>&1
370                               chown -R cimsrvr %PEGASUS_REPOSITORY_DIR
371                               chgrp -R cimsrvr %PEGASUS_REPOSITORY_DIR
372                           fi
373 yi.zhou          1.98     if [ -f %PEGASUS_TRACE_FILE_PATH ]; then
374                             /bin/mv %PEGASUS_TRACE_FILE_PATH %PEGASUS_TRACE_FILE_PATH-`date '+%Y-%m-%d-%R'`
375                           fi
376                           if [ "$isRunning" ]; then
377                               /etc/init.d/tog-pegasus start
378                           fi
379 w.otsuka         1.24  fi
380 denise.eckstein  1.74  
381 w.otsuka         1.1   %preun
382 denise.eckstein  1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
383                        #           install   remove   upgrade  reinstall
384                        #  preun       -        0         1         -
385 w.otsuka         1.24  if [ $1 -eq 0 ]; then
386 denise.eckstein  1.32     # Check if the cimserver is running
387 denise.eckstein  1.74     isRunning=`ps -el | grep cimserver |  grep -v "grep cimserver"`
388 denise.eckstein  1.32     if [ "$isRunning" ]; then
389 denise.eckstein  1.74        %PEGASUS_SBIN_DIR/cimserver -s
390                           fi 
391                           /sbin/chkconfig --del tog-pegasus;
392                           rm -f %PEGASUS_VARDATA_DIR/cimserver_current.conf;
393                           [ -d %PEGASUS_REPOSITORY_DIR ]  && rm -rf %PEGASUS_REPOSITORY_DIR;
394                           [ -d %PEGASUS_VARDATA_CACHE_DIR ]  && rm -rf %PEGASUS_VARDATA_CACHE_DIR;
395                           rm -f %PEGASUS_LOCAL_DOMAIN_SOCKET_PATH;
396                           rm -f %PEGASUS_CIMSERVER_START_FILE;
397 kumpf            1.94     rm -f %PEGASUS_CIMSERVER_START_LOCK_FILE;
398 w.otsuka         1.24  fi
399 denise.eckstein  1.74  #
400                        # End of section pegasus/rpm/tog-specfiles/tog-pegasus-preun.spec
401 w.otsuka         1.1   
402 w.otsuka         1.69  %preun devel
403 yi.zhou          1.106 # Check if the SDK has been setup
404                        if [ -f /usr/share/Pegasus/samples/SDKIsSetup ]; then
405                           make --directory /usr/share/Pegasus/samples -s unsetupSDK
406                           if [ $? != 0 ]; then
407                              echo "++++++++++++++++++++++++++++++++++++++++++++++" >&2
408                              echo "ERROR: Failed to deregister sample providers." >&2
409                              echo "To remove the SDK rpm without deregistering" >&2
410                              echo "the sample providers, first remove file" >&2
411                              echo "/usr/share/Pegasus/samples/SDKIsSetup," >&2
412                              echo "then remove SDK rpm." >&2
413                              echo "++++++++++++++++++++++++++++++++++++++++++++++" >&2
414                              exit 1
415                           fi
416                        fi
417 denise.eckstein  1.76  make --directory /usr/share/Pegasus/samples -s clean
418 denise.eckstein  1.44  
419 w.otsuka         1.56  %if %{PEGASUS_BUILD_TEST_RPM}
420 denise.eckstein  1.46  %preun test
421 denise.eckstein  1.76  make --directory /usr/share/Pegasus/test -s unsetupTEST
422                        [ -d /var/lib/Pegasus/testrepository ] &&  rm -rf /var/lib/Pegasus/testrepository;
423 denise.eckstein  1.46  
424 w.otsuka         1.56  %endif
425 w.otsuka         1.1   %postun
426 w.otsuka         1.24  if [ $1 -eq 0 ]; then
427 denise.eckstein  1.32     export LC_ALL=C
428 w.otsuka         1.1   fi
429 denise.eckstein  1.74  # Start of section pegasus/rpm/tog-specfiles/tog-pegasus-postun.spec
430                        #
431                        #           install   remove   upgrade  reinstall
432                        #  postun      -        0         1         -
433                        if [ $1 -eq 0 ]; then
434                           /usr/sbin/userdel pegasus > /dev/null 2>&1 || :;
435 w.otsuka         1.78     /usr/sbin/groupdel pegasus > /dev/null 2>&1 || :;
436 denise.eckstein  1.74  fi;
437                        #
438                        # End of section pegasus/rpm/tog-specfiles/tog-pegasus-postun.spec
439 w.otsuka         1.1   
440 yi.zhou          1.98  # When Privilege Separation is enabled, delete the 'cimsrvr' user and 
441 denise.eckstein  1.100 # 'cimsrvr' group which are used as the context of the cimservermain process
442 yi.zhou          1.98  if [ $1 -eq 0 ]; then
443                            /usr/sbin/userdel cimsrvr > /dev/null 2>&1 || :;
444 denise.eckstein  1.100     /usr/sbin/groupdel cimsrvr > /dev/null 2>&1 || :;
445 yi.zhou          1.98  fi
446                        
447 w.otsuka         1.1   %files
448 denise.eckstein  1.109 %defattr(600,cimsrvr,cimsrvr,700)
449 yi.zhou          1.98  /var/lib/Pegasus/repository
450 denise.eckstein  1.109 
451                        %defattr(644,root,pegasus,755)
452                        /usr/share/Pegasus/mof
453                        
454                        %defattr(600,root,pegasus,755)
455 denise.eckstein  1.113 %dir /usr/share/doc/tog-pegasus-2.9
456 denise.eckstein  1.76  %dir /usr/share/Pegasus
457                        %dir /usr/share/Pegasus/scripts
458                        %dir /var/lib/Pegasus
459                        %dir /var/lib/Pegasus/cache
460                        %dir /var/lib/Pegasus/log
461                        %dir /var/lib/Pegasus/cache/localauth
462 denise.eckstein  1.81  %dir /usr/%PEGASUS_ARCH_LIB/Pegasus 
463                        %dir /usr/%PEGASUS_ARCH_LIB/Pegasus/providers 
464 denise.eckstein  1.110 %dir /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers 
465 denise.eckstein  1.74  
466 denise.eckstein  1.109 %dir %attr(755,root,pegasus) /etc/Pegasus
467                        %dir %attr(755,cimsrvr,cimsrvr) /var/run/tog-pegasus
468 denise.eckstein  1.100 %dir %attr(1755,cimsrvr,cimsrvr) /var/run/tog-pegasus/socket
469 denise.eckstein  1.76  %dir %attr(1777,root,pegasus) /var/lib/Pegasus/cache/trace
470 denise.eckstein  1.74  
471                        %config %attr(750,root,pegasus) /etc/init.d/tog-pegasus
472 denise.eckstein  1.108 %config(noreplace) %attr(644,root,root) /var/lib/Pegasus/cimserver_planned.conf
473 denise.eckstein  1.76  %config(noreplace) /etc/Pegasus/access.conf
474 denise.eckstein  1.74  %config(noreplace) /etc/pam.d/wbem
475                        
476 denise.eckstein  1.76  %ghost %config(noreplace) /etc/Pegasus/ssl.cnf
477                        %ghost %config(noreplace) /etc/Pegasus/client.pem
478                        %ghost %config(noreplace) /etc/Pegasus/server.pem
479                        %ghost %config(noreplace) /etc/Pegasus/file.pem
480                        %ghost /var/lib/Pegasus/log/install.log
481                        
482 denise.eckstein  1.99  %attr(755,root,pegasus) /usr/sbin/*
483 denise.eckstein  1.76  %attr(755,root,pegasus) /usr/bin/*
484 denise.eckstein  1.81  %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/*.so.1
485                        %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/*.so.1
486 denise.eckstein  1.110 %attr(755,root,pegasus) /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers/*.so.1
487 denise.eckstein  1.76  %attr(750,root,pegasus) /usr/share/Pegasus/scripts/*
488                        %attr(644,root,pegasus) /usr/share/man/man1/*
489 denise.eckstein  1.101 %attr(644,root,pegasus) /usr/share/man/man8/*
490 denise.eckstein  1.76  
491 denise.eckstein  1.113 %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.9/Admin_Guide_Release.pdf
492                        %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.9/PegasusSSLGuidelines.htm
493                        %doc %attr(444,root,pegasus) /usr/share/doc/tog-pegasus-2.9/license.txt
494 denise.eckstein  1.81  /usr/%PEGASUS_ARCH_LIB/libpegclient.so
495                        /usr/%PEGASUS_ARCH_LIB/libpegcommon.so
496                        /usr/%PEGASUS_ARCH_LIB/libpegprovider.so
497                        /usr/%PEGASUS_ARCH_LIB/libDefaultProviderManager.so
498                        /usr/%PEGASUS_ARCH_LIB/libCIMxmlIndicationHandler.so
499 yi.zhou          1.93  /usr/%PEGASUS_ARCH_LIB/libsnmpIndicationHandler.so
500 denise.eckstein  1.81  /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libComputerSystemProvider.so
501                        /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libOSProvider.so
502                        /usr/%PEGASUS_ARCH_LIB/Pegasus/providers/libProcessProvider.so
503 denise.eckstein  1.110 /usr/%PEGASUS_ARCH_LIB/Pegasus/providerManagers/libCMPIProviderManager.so
504 w.otsuka         1.1   
505 w.otsuka         1.69  %files devel
506 denise.eckstein  1.76  %defattr(644,root,pegasus,755)
507 denise.eckstein  1.89  /usr/share/Pegasus/samples
508 w.otsuka         1.80  /usr/include/Pegasus
509 denise.eckstein  1.113 /usr/share/doc/tog-pegasus-2.9/*
510 denise.eckstein  1.76  /usr/share/Pegasus/html
511 w.otsuka         1.28  
512 w.otsuka         1.56  %if %{PEGASUS_BUILD_TEST_RPM}
513 w.otsuka         1.28  %files test
514 denise.eckstein  1.74  %defattr(-,root,pegasus,-)
515 denise.eckstein  1.114 
516                        %dir /usr/share/Pegasus/test
517                        %dir /usr/share/Pegasus/test/bin
518                        %dir /usr/share/Pegasus/test/%PEGASUS_ARCH_LIB
519                        %dir /usr/share/Pegasus/test/mak
520                        %dir /usr/share/Pegasus/test/tmp
521                        
522 yi.zhou          1.111 %ghost /usr/share/Pegasus/test/tmp/procIdFile
523                        %ghost /usr/share/Pegasus/test/tmp/trapLogFile
524                        %ghost /usr/share/Pegasus/test/tmp/IndicationStressTestLog
525 denise.eckstein  1.114 %ghost /usr/share/Pegasus/test/tmp/oldIndicationStressTestLog
526                        
527                        %attr(744,root,pegasus) /usr/share/Pegasus/test/bin/*
528                        %attr(744,root,pegasus) /usr/share/Pegasus/test/%PEGASUS_ARCH_LIB/*
529                        %attr(744,root,pegasus) /usr/share/Pegasus/test/mak/*
530                        %attr(644,root,pegasus) /usr/share/Pegasus/test/Makefile
531                        
532 denise.eckstein  1.100 %defattr(600,cimsrvr, cimsrvr,700)
533 denise.eckstein  1.76  /var/lib/Pegasus/testrepository
534 w.otsuka         1.56  %endif

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2