(file) Return to pegasus-1.0.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm

  1 sage  1.1 #
  2           # pegasus-1.0-spec
  3           #
  4           # Package spec for PEGASUS
  5           #
  6           
  7           Summary: PEGASUS CIMOM for Linux
  8           Name: pegasus
  9 mike  1.4 Autoreqprov:  on
 10 sage  1.1 Version: 1.0
 11 mike  1.4 Release: 5
 12 sage  1.1 Group: Systems Management/Base
 13           Copyright: MIT Public Licence
 14 mike  1.4 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
 15 sage  1.1 Packager: Markus Mueller <markus_mueller@de.ibm.com>
 16 sage  1.7 Provides: cimserver pegasus-1.0
 17 mike  1.4 URL:    http://www.opengroup.org/pegasus
 18           Source: ftp://www.opengroup.org/pegasus/pegasus-%{version}.tar.gz
 19 sage  1.1 
 20           #Patch0: cimom-peg1.patch.gz
 21           #Patch1: cimom-peg2.patch.gz
 22           
 23           %description
 24           Pegasus CIMOM enables a Linux System for WBEM (visit http://www.dmtf.org for
 25           more information about CIM and WBEM). With appropriate instrumentation
 26           Linux can provide systems management information or be managed by a remote
 27           client application.
 28 mike  1.4 This package requires the standard C-library, a threading library like
 29           linuxthreads or GNU pth and openssl.
 30           
 31           %package devel
 32           Summary:      The Pegasus source tree
 33           Group:        Systems Management/Base
 34 sage  1.7 Autoreq: 0
 35           Requires: pegasus-1.0
 36 mike  1.4 
 37           %description devel
 38           This package contains the Pegasus source tree, header files and
 39           static libraries (if any).
 40 sage  1.1 
 41           %prep
 42 sage  1.8 #clean up
 43 sage  1.1 rm -rf $RPM_BUILD_ROOT
 44 sage  1.8 
 45           %setup
 46 sage  1.5 # Copy the necessary include files
 47 sage  1.7 $PEGASUS_ROOT/rpm/buildincludes $PEGASUS_ROOT $RPM_BUILD_ROOT /usr/src/packages/BUILD/pegasus-1.0
 48 sage  1.1 
 49 mike  1.4 %build
 50 sage  1.1 export PEGASUS_ROOT=/usr/src/packages/BUILD/pegasus-1.0
 51 mike  1.4 export PEGASUS_HOME=$RPM_BUILD_ROOT/usr/pegasus-1.0
 52 sage  1.1 export PEGASUS_PLATFORM=LINUX_IX86_GNU
 53 sage  1.5 export PEGASUS_HAS_SSL=yes
 54 sage  1.1 make depend
 55           make
 56 sage  1.7 
 57 mike  1.4 #%ifarch ppc s390 s390x sparc sparc64
 58           #%endif
 59 sage  1.1 
 60           %install
 61           
 62 sage  1.7 # Copy the necessary include files
 63           #$PEGASUS_ROOT/rpm/buildincludes $PEGASUS_ROOT $RPM_BUILD_ROOT /usr/src/packages/BUILD/pegasus-1.0
 64           #testtest
 65           mkdir -p $RPM_BUILD_ROOT/usr/pegasus-1.0/bin
 66           touch $RPM_BUILD_ROOT/usr/pegasus-1.0/bin/blah
 67           
 68 sage  1.1 # Copy binaries and libraries
 69 mike  1.4 mkdir -p $RPM_BUILD_ROOT/usr/bin
 70           cp -a $RPM_BUILD_ROOT/usr/pegasus-1.0/bin/* $RPM_BUILD_ROOT/usr/bin
 71           mkdir -p $RPM_BUILD_ROOT/usr/lib
 72           cp -a $RPM_BUILD_ROOT/usr/pegasus-1.0/lib/* $RPM_BUILD_ROOT/usr/lib
 73 sage  1.1 
 74           # Copy the schema
 75           
 76 mike  1.4 mkdir -p $RPM_BUILD_ROOT/var/lib/pegasus/mof
 77           mkdir -p $RPM_BUILD_ROOT/var/lib/pegasus/repository
 78           cp -a $PEGASUS_ROOT/Schemas/CIM25/*.mof $RPM_BUILD_ROOT/var/lib/pegasus/mof
 79 sage  1.1 
 80           #
 81           mkdir -p $RPM_BUILD_ROOT/etc/rc.d/
 82           cp $PEGASUS_ROOT/rpm/pegasus $RPM_BUILD_ROOT/etc/rc.d/
 83           
 84           mkdir -p $RPM_BUILD_ROOT/var/pegasus/log
 85 mike  1.4 mkdir -p $RPM_BUILD_ROOT/var/lib/pegasus
 86 sage  1.1 mkdir -p $RPM_BUILD_ROOT/etc/pegasus
 87           touch $RPM_BUILD_ROOT/etc/pegasus/pegasus.conf
 88           
 89           #make INSTALLROOT=$RPM_BUILD_ROOT install
 90           #%__mkdir -p $RPM_BUILD_ROOT/usr/pegasus/lib/mof
 91           #%__mkdir -p $RPM_BUILD_ROOT/var/pegasus
 92           
 93 mike  1.4 %clean
 94           make clean
 95           [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
 96           
 97 sage  1.1 %post
 98           ldconfig
 99 mike  1.4 cimmof -R/var/lib/pegasus -I/var/lib/pegasus/mof -nroot /var/lib/pegasus/mof/CIM_Core25.mof
100           cimmof -R/var/lib/pegasus -I/var/lib/pegasus/mof -nroot/cimv2 /var/lib/pegasus/mof/CIM_Schema25.mof
101 sage  1.1 sbin/insserv etc/init.d/pegasus
102 mike  1.4 echo "please add the path /usr/lib/pegasus to the ld.so.conf"
103 sage  1.1 %postun
104 mike  1.4 rm -rf /var/lib/pegasus/repository
105 sage  1.1 sbin/insserv etc/init.d
106           
107 sage  1.6 %files devel -f rpm_pegasus_include_files
108 sage  1.1 
109           %defattr(-,root,root,0755)
110           %doc doc/*.txt doc/DOCREMARKS doc/HISTORY doc/NOTES
111           
112 mike  1.4 %files
113           
114 sage  1.7 #%dir %attr(-,root,root) /usr/bin
115           #%dir %attr(-,root,root) /usr/lib
116           #%dir %attr(-,root,root) /var/lib/pegasus/mof
117           
118 mike  1.4 %dir %attr(-,root,root) /usr/include
119 sage  1.1 %dir %attr(-,root,root) /var/pegasus/log
120 mike  1.4 %dir %attr(-,root,root) /var/lib/pegasus
121           %dir %attr(-,root,root) /var/lib/pegasus/repository
122 sage  1.1 
123           %config %attr(-,root,root) /etc/pegasus/pegasus.conf
124           %config %attr(-,root,root) /etc/rc.d/pegasus
125           
126 sage  1.5 %attr(-,root,root) /usr/lib/
127           
128           %attr(-,root,root) /usr/bin/
129 mike  1.4 
130 sage  1.5 %attr(-,root,root) /var/lib/pegasus/mof/

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2