(file) Return to lsb-pegasus.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm

File: [Pegasus] / pegasus / rpm / Attic / lsb-pegasus.spec (download)
Revision: 1.1, Thu Jul 1 02:22:11 2004 UTC (19 years, 11 months ago) by konrad.r
Branch: MAIN
CVS Tags: pegasus25BeforeLicenseUpdate, STABLE, SLPPERFINST-root, SLPPERFINST-branch, RELEASE_2_5_0-RC1, RELEASE_2_5_0, RELEASE_2_4_FC_CANDIDATE_1, RELEASE_2_4_3, RELEASE_2_4_2, RELEASE_2_4_1-BETA3, RELEASE_2_4_1-BETA2, RELEASE_2_4_1-BETA1, RELEASE_2_4_1, RELEASE_2_4_0-RC3, RELEASE_2_4_0-RC2, RELEASE_2_4_0, RELEASE_2_4-root, RELEASE_2_4-branch, PEP244_ServerProfile-root, PEP244_ServerProfile-branch, PEP233_EmbeddedInstSupport-root, PEP217_PRE_BRANCH, PEP217_POST_BRANCH, PEP217_BRANCH, PEP214ROOT, PEP214BRANCH, PEP214-root, PEP214-branch, PEP213_SIZE_OPTIMIZATIONS, PEP-214B-root, PEGASUS_2_5_0_PerformanceDev-string-end, PEGASUS_2_5_0_PerformanceDev-rootlt, PEGASUS_2_5_0_PerformanceDev-root, PEGASUS_2_5_0_PerformanceDev-r2, PEGASUS_2_5_0_PerformanceDev-r1, PEGASUS_2_5_0_PerformanceDev-lit-end, PEGASUS_2_5_0_PerformanceDev-buffer-end, PEGASUS_2_5_0_PerformanceDev-branch, PEGASUS_2_5_0_PerformanceDev-AtomicInt-branch, PEG25_IBM_5_16_05, NPEGASUS_2_5_0_PerformanceDev-String-root, NNPEGASUS_2_5_0_PerformanceDev-String-branch, MONITOR_CONSOLIDATION_2_5_BRANCH, IBM_241_April1405, CQL_2_5_BRANCH, CHUNKTESTDONE_PEP140, BUG_4225_PERFORMANCE_VERSION_1_DONE
Branch point for: PEP233_EmbeddedInstSupport-branch
PEP#: 152
TITLE: Make Pegasus LSB compliant

DESCRIPTION:
a). New spec file.
b). New XML file for building the LSB compliant RPM
c). Added configuration options in the cimserver_planned.conf
d). New init script

#%/////////////////////////////////////////////////////////////////////////////
#
# Copyright (c) 2004 BMC Software, Hewlett-Packard Company, IBM,
# The Open Group, Tivoli Systems
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to
# deal in the Software without restriction, including without limitation the
# rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
# sell copies of the Software, and to permit persons to whom the Software is
# furnished to do so, subject to the following conditions:
# 
# THE ABOVE COPYRIGHT NOTICE AND THIS PERMISSION NOTICE SHALL BE INCLUDED IN
# ALL COPIES OR SUBSTANTIAL PORTIONS OF THE SOFTWARE. THE SOFTWARE IS PROVIDED
# "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
# LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
# PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
#
#==============================================================================
#
# Author: Konrad Rzeszutek <konradr@us.ibm.com>
#
#%/////////////////////////////////////////////////////////////////////////////
#
# Package spec for OpenPegasus 2.4
#
Summary: WBEM Services for Linux
Name: lsb-pegasus
Version: 2.4
Release: 1
Group: Systems Management/Base
Vendor: OpenSource Org
Copyright: Open Group Pegasus Open Source
BuildRoot: /home/konrad/MAIN/install
Requires: openssl-devel >= 0.9.6 lsb >= 1.3
Provides: cimserver lsb-pegasus

%description
WBEM Services for Red Hat Linux enables management solutions that deliver
increased control of enterprise resources. WBEM is a platform and resource
independent DMTF standard that defines a common information model and
communication protocol for monitoring and controlling resources from diverse
sources.


%pre

%install

%post
chmod 755 /etc/init.d/lsb-pegasus
/usr/lib/lsb/install_initd /etc/init.d/lsb-pegasus

CN="Common Name"
EMAIL="test@email.address"
HOSTNAME=`uname -n`
sed -e "s/$CN/$HOSTNAME/"  \
    -e "s/$EMAIL/root@$HOSTNAME/" /var/opt/lsb-pegasus/ssl.orig \
    > /var/opt/lsb-pegasus/ssl.cnf
chmod 644 /var/opt/lsb-pegasus/ssl.cnf
chown bin /var/opt/lsb-pegasus/ssl.cnf
chgrp bin /var/opt/lsb-pegasus/ssl.cnf

openssl req -x509 -days 365 -newkey rsa:2048 \
   -nodes -config /var/opt/lsb-pegasus/ssl.cnf   \
   -keyout /etc/opt/lsb-pegasus/key.pem -out /etc/opt/lsb-pegasus/cert.pem 

cat /etc/opt/lsb-pegasus/key.pem > /etc/opt/lsb-pegasus/file_2048.pem
cat /etc/opt/lsb-pegasus/cert.pem > /etc/opt/lsb-pegasus/server_2048.pem
cat /etc/opt/lsb-pegasus/cert.pem > /etc/opt/lsb-pegasus/client_2048.pem
chmod 700 /etc/opt/lsb-pegasus/*.pem

rm -f /etc/opt/lsb-pegasus/key.pem /etc/opt/lsb-pegasus/cert.pem

if [ -f /etc/opt/lsb-pegasus/server.pem ] 
then
    echo "WARNING: /etc/opt/lsb-pegasus/server.pem SSL Certificate file already exists."
else
    cp /etc/opt/lsb-pegasus/server_2048.pem /etc/opt/lsb-pegasus/server.pem
    cp /etc/opt/lsb-pegasus/file_2048.pem /etc/opt/lsb-pegasus/file.pem
    chmod 400 /etc/opt/lsb-pegasus/server.pem /etc/opt/lsb-pegasus/file.pem
fi

if [ -f /etc/opt/lsb-pegasus/client.pem ]
then
    echo "WARNING: /etc/opt/lsb-pegasus/client.pem SSL Certificate trust store already exists."
else
    cp /etc/opt/lsb-pegasus/client_2048.pem /etc/opt/lsb-pegasus/client.pem
    chmod 400 /etc/opt/lsb-pegasus/client.pem
fi

%postun
/usr/lib/lsb/remove_initd /etc/init.d/lsb-pegasus

%files

%attr ( - bin bin) /opt/lsb-pegasus
%attr ( - bin bin) /etc/opt/lsb-pegasus
%attr ( - bin bin) /etc/init.d/lsb-pegasus
%attr ( - bin bin) /etc/pam.d/wbem
%attr ( - bin bin) /var/opt/lsb-pegasus/

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2