(file) Return to lsb-pegasus.spec CVS log (file) (dir) Up to [Pegasus] / pegasus / rpm

  1 a.dunfey 1.1.28.1 #//%2006////////////////////////////////////////////////////////////////////////
  2                   #//
  3                   #// Copyright (c) 2000, 2001, 2002 BMC Software; Hewlett-Packard Development
  4                   #// Company, L.P.; IBM Corp.; The Open Group; Tivoli Systems.
  5                   #// Copyright (c) 2003 BMC Software; Hewlett-Packard Development Company, L.P.;
  6                   #// IBM Corp.; EMC Corporation, The Open Group.
  7                   #// Copyright (c) 2004 BMC Software; Hewlett-Packard Development Company, L.P.;
  8                   #// IBM Corp.; EMC Corporation; VERITAS Software Corporation; The Open Group.
  9                   #// Copyright (c) 2005 Hewlett-Packard Development Company, L.P.; IBM Corp.;
 10                   #// EMC Corporation; VERITAS Software Corporation; The Open Group.
 11                   #// Copyright (c) 2006 Hewlett-Packard Development Company, L.P.; IBM Corp.;
 12                   #// EMC Corporation; Symantec Corporation; The Open Group.
 13                   #//
 14                   #// Permission is hereby granted, free of charge, to any person obtaining a copy
 15                   #// of this software and associated documentation files (the "Software"), to
 16                   #// deal in the Software without restriction, including without limitation the
 17                   #// rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
 18                   #// sell copies of the Software, and to permit persons to whom the Software is
 19                   #// furnished to do so, subject to the following conditions:
 20                   #// 
 21                   #// THE ABOVE COPYRIGHT NOTICE AND THIS PERMISSION NOTICE SHALL BE INCLUDED IN
 22 a.dunfey 1.1.28.1 #// ALL COPIES OR SUBSTANTIAL PORTIONS OF THE SOFTWARE. THE SOFTWARE IS PROVIDED
 23                   #// "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
 24                   #// LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
 25                   #// PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
 26                   #// HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
 27                   #// ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
 28                   #// WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
 29                   #//
 30                   #//==============================================================================
 31 konrad.r 1.1      #%/////////////////////////////////////////////////////////////////////////////
 32                   #
 33                   # Copyright (c) 2004 BMC Software, Hewlett-Packard Company, IBM,
 34                   # The Open Group, Tivoli Systems
 35                   #
 36                   # Permission is hereby granted, free of charge, to any person obtaining a copy
 37                   # of this software and associated documentation files (the "Software"), to
 38                   # deal in the Software without restriction, including without limitation the
 39                   # rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
 40                   # sell copies of the Software, and to permit persons to whom the Software is
 41                   # furnished to do so, subject to the following conditions:
 42                   # 
 43                   # THE ABOVE COPYRIGHT NOTICE AND THIS PERMISSION NOTICE SHALL BE INCLUDED IN
 44                   # ALL COPIES OR SUBSTANTIAL PORTIONS OF THE SOFTWARE. THE SOFTWARE IS PROVIDED
 45                   # "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
 46                   # LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
 47                   # PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
 48                   # HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
 49                   # ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
 50                   # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
 51                   #
 52 konrad.r 1.1      #==============================================================================
 53                   #
 54                   # Author: Konrad Rzeszutek <konradr@us.ibm.com>
 55                   #
 56                   #%/////////////////////////////////////////////////////////////////////////////
 57                   #
 58                   # Package spec for OpenPegasus 2.4
 59                   #
 60                   Summary: WBEM Services for Linux
 61                   Name: lsb-pegasus
 62                   Version: 2.4
 63                   Release: 1
 64                   Group: Systems Management/Base
 65                   Vendor: OpenSource Org
 66                   Copyright: Open Group Pegasus Open Source
 67                   BuildRoot: /home/konrad/MAIN/install
 68                   Requires: openssl-devel >= 0.9.6 lsb >= 1.3
 69                   Provides: cimserver lsb-pegasus
 70                   
 71                   %description
 72                   WBEM Services for Red Hat Linux enables management solutions that deliver
 73 konrad.r 1.1      increased control of enterprise resources. WBEM is a platform and resource
 74                   independent DMTF standard that defines a common information model and
 75                   communication protocol for monitoring and controlling resources from diverse
 76                   sources.
 77                   
 78                   
 79                   %pre
 80                   
 81                   %install
 82                   
 83                   %post
 84                   chmod 755 /etc/init.d/lsb-pegasus
 85                   /usr/lib/lsb/install_initd /etc/init.d/lsb-pegasus
 86                   
 87                   CN="Common Name"
 88                   EMAIL="test@email.address"
 89                   HOSTNAME=`uname -n`
 90                   sed -e "s/$CN/$HOSTNAME/"  \
 91                       -e "s/$EMAIL/root@$HOSTNAME/" /var/opt/lsb-pegasus/ssl.orig \
 92                       > /var/opt/lsb-pegasus/ssl.cnf
 93                   chmod 644 /var/opt/lsb-pegasus/ssl.cnf
 94 konrad.r 1.1      chown bin /var/opt/lsb-pegasus/ssl.cnf
 95                   chgrp bin /var/opt/lsb-pegasus/ssl.cnf
 96                   
 97                   openssl req -x509 -days 365 -newkey rsa:2048 \
 98                      -nodes -config /var/opt/lsb-pegasus/ssl.cnf   \
 99                      -keyout /etc/opt/lsb-pegasus/key.pem -out /etc/opt/lsb-pegasus/cert.pem 
100                   
101                   cat /etc/opt/lsb-pegasus/key.pem > /etc/opt/lsb-pegasus/file_2048.pem
102                   cat /etc/opt/lsb-pegasus/cert.pem > /etc/opt/lsb-pegasus/server_2048.pem
103                   cat /etc/opt/lsb-pegasus/cert.pem > /etc/opt/lsb-pegasus/client_2048.pem
104                   chmod 700 /etc/opt/lsb-pegasus/*.pem
105                   
106                   rm -f /etc/opt/lsb-pegasus/key.pem /etc/opt/lsb-pegasus/cert.pem
107                   
108                   if [ -f /etc/opt/lsb-pegasus/server.pem ] 
109                   then
110                       echo "WARNING: /etc/opt/lsb-pegasus/server.pem SSL Certificate file already exists."
111                   else
112                       cp /etc/opt/lsb-pegasus/server_2048.pem /etc/opt/lsb-pegasus/server.pem
113                       cp /etc/opt/lsb-pegasus/file_2048.pem /etc/opt/lsb-pegasus/file.pem
114                       chmod 400 /etc/opt/lsb-pegasus/server.pem /etc/opt/lsb-pegasus/file.pem
115 konrad.r 1.1      fi
116                   
117                   if [ -f /etc/opt/lsb-pegasus/client.pem ]
118                   then
119                       echo "WARNING: /etc/opt/lsb-pegasus/client.pem SSL Certificate trust store already exists."
120                   else
121                       cp /etc/opt/lsb-pegasus/client_2048.pem /etc/opt/lsb-pegasus/client.pem
122                       chmod 400 /etc/opt/lsb-pegasus/client.pem
123                   fi
124                   
125                   %postun
126                   /usr/lib/lsb/remove_initd /etc/init.d/lsb-pegasus
127                   
128                   %files
129                   
130                   %attr ( - bin bin) /opt/lsb-pegasus
131                   %attr ( - bin bin) /etc/opt/lsb-pegasus
132                   %attr ( - bin bin) /etc/init.d/lsb-pegasus
133                   %attr ( - bin bin) /etc/pam.d/wbem
134                   %attr ( - bin bin) /var/opt/lsb-pegasus/

No CVS admin address has been configured
Powered by
ViewCVS 0.9.2